Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Front windscreen washer noisy & ineffective
#1
Over the past few weeks the front windscreen washer on my Berlingo has become really ineffective. When pulling back on the wiper lever there are a few seconds of motor noise before the water starts to come out and when it does there is almost no pressure. After a few seconds it improves a little but not much, certainly not like it was a month ago. The pump is noisy as well. If you wait and try again then it still has a few seconds of nothing as if it has to prime the system each time. The rear washer is working fine, no extra pump noise and a good jet of water.

Are there two pumps? Where even are they? The filling tube is at the front but the pump noise comes from the back of the engine around the wheel arch.
Does it sound like I need a new pump and is it an expensive job?

I have a 2005 2.0L Diesel Berlingo with 154000 on the clock (all my miles!).

Thanks :-)
Citroen Berlingo 2.0 HDi Desire 2005
Reply
#2
Try flushing out the reservoir.You can fiddle a hose in if you warm it first.Push to bottom of tank & give as much pressure as poss.Keep going 'till water is clear.Then check pipes to jets & jets themselves.If this doesn't help,it's strip down time by removing the arch liner & checking pump.Good luck.PS I think it's only 1 pump.
Strawberry flavoured windows  Dodgy
[+] 1 user says Thank You to ron for this post
Reply
#3
Ron is correct its just one pump pushed into the washer bottle body. You need to remove the wheel and inner arch to get at it. Watch the rubber seal between pump and bottle and there is an o ring where the neck fits in the bottle to that you need to lube when you fit it back together. You could have a load of jelly like scum build up in the bottle caused by rubbish screen wash blocking the pump and pipes orit could be the pump. A pump is about a tenner and it aint a big job to do.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply
#4
Try removing the piping from the windscreen outlet nozzles and then operating the pump, is the water coming out ok ?
[+] 1 user says Thank You to geoff for this post
Reply
#5
(13-08-2015, 12:55 PM)petet66 Wrote:  Over the past few weeks the front windscreen washer on my Berlingo has become really ineffective. When pulling back on the wiper lever there are a few seconds of motor noise before the water starts to come out and when it does there is almost no pressure. After a few seconds it improves a little but not much, certainly not like it was a month ago. The pump is noisy as well. If you wait and try again then it still has a few seconds of nothing as if it has to prime the system each time. The rear washer is working fine, no extra pump noise and a good jet of water.

Are there two pumps? Where even are they? The filling tube is at the front but the pump noise comes from the back of the engine around the wheel arch.
Does it sound like I need a new pump and is it an expensive job?

I have a 2005 2.0L Diesel Berlingo with 154000 on the clock (all my miles!).

Thanks :-)

Had the same problem with my 02/ 1.9. but it was the rear that had no pressure.It only has one wiper washer motor that does both back and front .This is behind the offside wheel arch cover which you will have to remove,before you do this though make sure you get some spare plastic fixings as they always break ! Although the pump is factory sealed it can be stripped ,its a little fiddly but do-able, i cant remember what exactly went wrong with mine but i remember it was obvious when i took the pump apart and easy to rectify with a little patience and its been perfect ever since.Oh by the way they are very cheep to buy on ebay if your not a practical man.
[+] 2 users say Thank You to bikergraham for this post
Reply
#6
(13-08-2015, 04:22 PM)geoff Wrote:  Try removing the piping from the windscreen outlet nozzles and then operating the pump, is the water coming out ok ?

Not to the front washers but the back is fine. Sounds like a blockage somewhere as it's just one pump.
Citroen Berlingo 2.0 HDi Desire 2005
Reply
#7
Is there anything I can use to flush through the pump to try to clear any blockages (if it's just washer fluid build up) without having to take it all apart of damaging the system?
Citroen Berlingo 2.0 HDi Desire 2005
Reply
#8
Hot water and a tube of denture cleaning tablets in the washer bottle then if the pump is working pump it through. But bear in mind the bottle could be lined with scum and its best to take the tank out and wash it. If you cant be bothered to remove the tank a short cut is remove the one screw holding the filler neck on and then put cleaner in the bottle and hot water, leave for 30 minutes then wash out with a hose pipe. Be careful of the o ring when you put the filler neck back in put soap or Vaseline on it.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply
#9
Have you any compressed air ? I've used this before now to blow these lines clear unless you have good lungs of course.

If you can do this then it would be advisable to flush the tank with a hose ( in situ ).
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Heated wing mirrors
Last Post:Bricky Ken
Yesterday 11:57 PM
» Replies: 0
» Views: 16
1.6 hdi 90bhp Turbo and i...
Last Post:Floydster
Yesterday 11:07 PM
» Replies: 1
» Views: 81
how many miles on yours ?
Last Post:Silverberlingo
Yesterday 10:59 PM
» Replies: 17
» Views: 766
1.6 16v petrol cambelt
Last Post:geoff
Yesterday 10:24 PM
» Replies: 5
» Views: 114
Door locking but unlocked
Last Post:DanielEZY0252
Yesterday 09:45 PM
» Replies: 0
» Views: 13
12v for lighter front
Last Post:Jed Clampit
Yesterday 09:07 PM
» Replies: 8
» Views: 184
2.0 HDi fuel issues as pe...
Last Post:G.mk3
Yesterday 07:17 PM
» Replies: 5
» Views: 69
zx1 extralube
Last Post:sks01773
Yesterday 06:07 PM
» Replies: 0
» Views: 42
citroen berlingo desire 1...
Last Post:sks01773
Yesterday 05:57 PM
» Replies: 5
» Views: 135
2012 enterprise berlingo ...
Last Post:Johny555
Yesterday 05:37 PM
» Replies: 9
» Views: 211

Locations of visitors to this page