Thread Rating:
  • 10 Vote(s) - 3.8 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Temp Gauge and Fan
#1
Hi All,

Iv got a 1999 T Reg 600lx. The temp gauge stopped working the other day, the needle sits just below the bottom bar and moves about 2mm when its been running for 10mins. A little investigation and i believe its the temp switch as i noticed the fan didn't kick in after 15mins of running.

Took the plug off the switch and bridges the pins and the temp gauge shot up to max (which is what I hoped) and the fan worked.

Ok but here is my problem, i went to Euro Parts to get the new switch but they didn't stock the part as standard and said it would be a special order and take 5days. So then went to Camberely Autos and they said the same thing?!?!? Very strange for a temp sensor. So finally went to a Citroen dealer and they said according to there system they had never sold one before in all the branches. So I asked the guy why so rare and as my Van has AirCon he said they hardly made any of the Mk1's with AirCon (is this true?).

He said he could order the part from France but again would take 5days and cost £45+Vat...

So my question is has anyone had the same problem? Where can I get the part that might be in stock. The Part No is 133887 and its a temp sensor with 4 pins and a blue top. Hours of Googling hasn't worked..

Thank You

Steve

Reply
#2
I use this suppler and they are very reliable in my experience. Did a search on your part number.

Tom
2010 Berlingo Multispace HDi 110 with FAP. Persamos green.

[Image: ab197646.gif]
Reply
#3
sounds like the temp gauge is ok.perhaps its the thermastat thats stuck open so its not getting warm and the gauge is telling you this.
thermostat
Reply
#4
Managed to get the Temp Sensor from All Parts in Croydon and was £30. Changed this evening and sorted the problem out :-)
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
2.0 HDi fuel issues as pe...
Last Post:brodfather11
Today 02:05 PM
» Replies: 13
» Views: 217
Haynes manuals - which on...
Last Post:ffrenchie
Today 01:54 PM
» Replies: 4
» Views: 44
Amateur radio
Last Post:ghost123uk
Today 01:41 PM
» Replies: 24
» Views: 8208
peugeot charger
Last Post:grig
Today 01:05 PM
» Replies: 0
» Views: 12
Poor cold startup 1.9
Last Post:Top drive
Today 12:52 PM
» Replies: 17
» Views: 521
Roof noise
Last Post:Shawks
Today 12:03 PM
» Replies: 6
» Views: 165
Heyup
Last Post:ffrenchie
Today 11:08 AM
» Replies: 6
» Views: 281
Fuel flap
Last Post:3rensho
Today 10:01 AM
» Replies: 1
» Views: 42
Poor cold starting. Whats...
Last Post:geoff
Today 09:18 AM
» Replies: 10
» Views: 180
lubricating door
Last Post:ghost123uk
Today 09:13 AM
» Replies: 7
» Views: 166

Locations of visitors to this page