Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hello my name is Loren and My partners Name is Nev and we have just purchased a second hand 2004 Citroen Berlingo 1.4i petrol and we brought it as we both run a karaoke business and needed the room to carry our equipment. since picking it up we have had it to two different garages withthe engine warning light coming on and they have guessed what is wrong with it and have not told us what the reason for light coming on is, there were past history codes on the ECU and they have been cleared and some have come back the codes they foundrelavant codes relating to the MAP Sensor, Intake Air Sensor, Cylinder Misfires, but they could not tell us what the problem real is, they removed the codes and some came back, they cleaned the MAP Sensor and fault still present, removed coils and plugs from the vehicle and inspected they seemed to be ok at time of inspection, Air box was not secure and sealed so removed and refit and re tightened the attached hose clamp fault was still present. The vehicle report said the Air Box is Damaged and Tappat Cover Gasket is Leaking. Could anyone help us please with what codes these would relate to and possibly what to do to fix these problems. Thanks Loren & Nev.
Hello Loren and Nev and welcome to the forum. It would help if you could list the codes that are recurring. Then I'm sure someone will be along to give you some advice.
2010 Berlingo Multispace HDi 110 with FAP. Persamos green.

[Image: ab197646.gif]
(30-08-2015, 04:48 AM)3rensho Wrote:  Hello Loren and Nev and welcome to the forum.  It would help if you could list the codes that are recurring.  Then I'm sure someone will be along to give you some advice.

Hi!, We are sorry we can not list the recurring codes as the Repco auto repairers that we took it to did not list the codes that were recurring they just put what I wrote in the message previous. At the moment the engine management light is off has been since we picked it up from repco auto repairer. I started the vehicle this morning it seemed to run good once the temperature got to the 60 degrees in temperature the engine started to miss. Because it is running so slow it wants to stall, when I rev the engine up to me it appears to be running ok engine management light does not appear when it is idleing or when it is revved up. The tacho/rev counter is only sitting on 900 RPM when it seems  to be missing, when it is running ok the tacho/rev counter sits on 1000 RPM. If you wish for more information I will ring the repco auto repairer tomorrow the 31st August, I will ask them if I can get the codes as not sure if they kept the codes that you require as it was friday 28th august that we got the car back from them. I hope the information I have given you will be sufficient to help you with this problem.
Look forward to hearing from you again I do appreciate your help in this matter it does frustrate me as in the old days before computers were put in the cars i used to be quiet the mechanic, if i had a miss in the car i could fix it myself quiet easily not game to touch the cars these days as i am afraid i may mess up the computer.
Thank you Loren & Nev.
Perhaps someone will be along that can give you some pointers from your description of the problems. A basic code reader can be had pretty inexpensively. I use a smart phone app called Torque and my phone is paired with a bluetooth dongle attached to the car. If you have a laptop, a program called DiagBox is an option (along with the car interface) but that would be a bit more dollar wise.
2010 Berlingo Multispace HDi 110 with FAP. Persamos green.

[Image: ab197646.gif]

With so many different faults showing up, I'd look for a common denominator. Maybe damage to the wiring loom?
Hello NLBerlingo welcome to the forum Smile  i think what you need to change the coil pack when it's getting warm / Hot it's starting to brake down it sit's on top of the spark plug's
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy

hi, have van booked in at the citreon dealer here for tuesday the 8.9.2015 to get it checked over to see if they can fix it for us will keep you updated on outcome thank you everyone for your responses and assistance it was greatly appreciated. Loren and Nev
hi all,
just an update on the berlingo, we were taking the berlingo to a citroen dealer to get looked at on hte 8th september were 11kms away from our desination when car stalled nev pulled the car over to side of road out of traffic went to start car again and smoke was bellowing from under bonnet so turned it off again and got our stuff out of car and up it went on fire was total write off so no more car burnt whole front end motor was sitting on the ground all burnt out not repairable the accessor said it was electrical and worte it off as a total loss this happened at 7.30am on 8th September, it was very stressful having to stand there and watch it burn, and being so far away from home was even more stressing as to how we were going to get home ended up getting a hire car through our insurance now we have a toyota camry. So thanks everyone for the help it was greatly appreciated this will be the end of our time on the forum as no need to get on here anymore. we brought some locks on Ebay for the van and they arriveds after the van went up in smoke so now have four locks no van. Thank you Bye.
WOW Sorry for your loss Sad lucky escape you sure you won't bye another berlingo there not all bad ??
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy

Wow, that's a shame! Least the two of you are OK.

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Roof bars for VTR?
Last Post:Jed Clampit
Yesterday 09:40 PM
» Replies: 4
» Views: 84
2005 Berlingo - Aussie Ow...
Last Post:martybelfasthdi
Yesterday 07:50 PM
» Replies: 14
» Views: 262
Eco activated but engine ...
Last Post:doofer
Yesterday 07:50 PM
» Replies: 22
» Views: 503
Front camber out of align...
Last Post:Col
Yesterday 06:46 PM
» Replies: 11
» Views: 236
My Berlingo Camper build....
Last Post:knownowt
Yesterday 06:40 PM
» Replies: 5
» Views: 285
P1351 fault code.
Last Post:Boxer
Yesterday 06:28 PM
» Replies: 13
» Views: 768
Upgrading DAB radio recep...
Last Post:Tree
Yesterday 06:26 PM
» Replies: 14
» Views: 2517
Overheating & part number...
Last Post:kevin58
Yesterday 05:55 PM
» Replies: 36
» Views: 17324
Last Post:ron
Yesterday 04:20 PM
» Replies: 4
» Views: 89
Speedo light not working?
Last Post:brodfather11
Yesterday 04:11 PM
» Replies: 1
» Views: 41

Locations of visitors to this page