Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fault codes P0401 & P0409
#1
These have been bugging me for a long time. Had both codes P0401 and P0409 for a while on my OBD and they won't go away. New sensor, cleaned and refitted the EGR but don't want to go down the new EGR route as they are 200 and scrapyard won't sell them! Any ideas?
Reply
#2
(06-09-2015, 03:01 PM)osborneelectric Wrote:  These have been bugging me for a long time. Had both codes P0401 and P0409 for a while on my OBD and they won't go away. New sensor, cleaned and refitted the EGR but don't want to go down the new EGR route as they are 200 and scrapyard won't sell them! Any ideas?

What engine you have ? Do you have lexia?
Generic OBD code can be misleading...
Reply
#3
1.6 hdi. Lexia not yet. Code p0401 is the stickler
Reply
#4
(13-09-2015, 08:00 PM)osborneelectric Wrote:  1.6 hdi. Lexia not yet. Code p0401 is the stickler

Check if EGR valve is moving freely . Separate lower part from upper. Turn by hand. Check for sticking.
Here is more info: http://www.berlingoforum.co.uk/thread-12042.html


Best regards,
brajomobil
Reply
#5
Also check electrically. If it's not powered, it won't move.
Reply
#6
Thank all for replies. Got that one cleaned and sorted. Now I'm seeing P0105? MAP sensor? Any clues? Thanks
Reply
#7
Some of the crap dislodged from the EGR ended up on the MAP?
Reply
#8
Hi there

Did you try to clean all errors in your OBD after install the sensor and reffing of the EGR Valve?

The ideia is to clean all erros and then put the engine working again.....(maybe you did that already)

I had problems with the EGR valve and The sensor that measures the rotation on the camsahft
Reply
#9
(14-09-2015, 08:18 PM)osborneelectric Wrote:  Thank all for replies. Got that one cleaned and sorted. Now I'm seeing P0105? MAP sensor? Any clues? Thanks

Yes. Please plug in Lexia and you can see what is the % opening of the EGR when P0105 occurred.
Then you can rule out EGR. You can also check/change MAP sensor, but I doubt faulty sensor is the problem.
Probably EGR is faulty and it is opening too much causing MAP to report P0105

You can test MAP : http://www.berlingoforum.co.uk/thread-10221.html
[+] 1 user says Thank You to brajomobil for this post
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
DW8 engine tapping
Last Post:jj9
Today 01:14 AM
» Replies: 3
» Views: 91
Rear window heater repair
Last Post:Silverberlingo
Yesterday 11:38 PM
» Replies: 0
» Views: 25
New PureTech 110 S&S Flai...
Last Post:Jed Clampit
Yesterday 09:04 PM
» Replies: 3
» Views: 56
What website to pass time...
Last Post:Solent
Yesterday 08:32 PM
» Replies: 0
» Views: 32
Berlingo Parts
Last Post:Sb12
Yesterday 07:56 PM
» Replies: 0
» Views: 34
Rear hub nut torque setti...
Last Post:jj9
Yesterday 07:55 PM
» Replies: 15
» Views: 261
temperatue dial
Last Post:Kokain
Yesterday 05:28 PM
» Replies: 3
» Views: 76
Trip Computer on Type A M...
Last Post:cancunia
Yesterday 03:50 PM
» Replies: 0
» Views: 25
Loud beeping from radio u...
Last Post:nicko
Yesterday 03:49 PM
» Replies: 3
» Views: 115
Ligts won't go off!
Last Post:Berlingos12
Yesterday 02:50 PM
» Replies: 10
» Views: 470

Locations of visitors to this page