Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Odometer and speedo not working
#1
Hi there
Last 2 days i had no working odometer or speedometer.
Is there a quick fix, like a sensor or something i can change "fast"?
Or is it something i need to take into shop to fix?

I looked trough other threads, about finding the "sensor" But i could only find what i think is the RPM sensor.
My Car INFO:
CITROËN BERLINGO (MF) 1.4 i (MFKFX, MFKFW)
2005 Mod
Volum: 1360 KW: 55 HK: 75 Fuel: Gasoline
Reply
#2
There should be a sensor on the gearbox.
Incidentally, a 2005 is a M59, not an M49.

Where in Norway are you?
Reply
#3
Yes, sensor is at the back of the gearbox, just above where the right hand (from sitting in car) driveshaft enters the gearbox.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Running on chip oil
Last Post:cancunia
Today 09:51 AM
» Replies: 4
» Views: 62
2004 Berlino Aerial
Last Post:malgpz900
Today 09:37 AM
» Replies: 3
» Views: 56
2005 2.0 HDI Siemens pump...
Last Post:cancunia
Today 09:05 AM
» Replies: 1
» Views: 54
1.6 hdi 90bhp Turbo and i...
Last Post:peteh80
Today 06:58 AM
» Replies: 4
» Views: 232
Poor cold startup 1.9
Last Post:Top drive
Today 12:24 AM
» Replies: 40
» Views: 1107
Washers not working
Last Post:Lighty
Yesterday 09:09 PM
» Replies: 11
» Views: 321
Reverse light switch prob...
Last Post:Col
Yesterday 07:22 PM
» Replies: 12
» Views: 285
Fuse is burning all the t...
Last Post:fernandoblas
Yesterday 05:23 PM
» Replies: 12
» Views: 423
HELP! Smashed passenger w...
Last Post:Sootyfoot
Yesterday 04:31 PM
» Replies: 2
» Views: 89
Diagnostic "gear" / Softw...
Last Post:cancunia
Yesterday 04:19 PM
» Replies: 15
» Views: 631

Locations of visitors to this page