Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
wont rev up over 3000rpm
picked up my car today started driving fine reved properly then all of a sudden wouldnt rev. drove it home let it sit for 10 mins and it reved fine then started playing up again i stuck my diagnostic onto it and came back with a egr flow problem
 any ideas what it is
No revs over 3k ???? must be a long distant cousin to VW ...... sorry couldn't resist !
lol the berlingo Franco
It looks to have gone into safe mode, which keeps it below 3000 revs to prevent engine damage. I'm surprised there isn't another fault code as low EGR flow should not trigger it, many people have theirs blocked off.
Could be worth trying a different code reader.
[+] 1 user says Thank You to JohnM for this post
First you need to if the EGR is opening and closing properly the best thing to do is take it off and clean it not an easy job then you can see how blocked it is and if it's no good . The other thing you can is blank it off to stop the crud form bocking the EGR and the inlet manifold or have it deleted some frown on this it will go through an MOT so it's up to you .
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy

[+] 1 user says Thank You to Jed Clampit for this post
it seems to reset its self if I turn the car off and lock and unlock it
whats the best way to get to the egr is it from the top or underneath?
I don't think the cars been driven much outside the city so that could be to blame
I'm going to blank the egr and might fit a fmic just because ive got a spare one before it goes for a remap
From the top on the right hand side at the back under the air filter and behind the fuel filter both will need to moved to get to the EGR good luck take your time
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy

got a blanking plate but it goes onto the pipe that joins the inlet manifold not made any difference so just gone and bought a new egr hope that sorts it
new egr valve fitted and still in limp mode showing up a p0401 fault code. ive pulled the pipe off the egr and there is no vacuum at all but there is a vacuum at the t piece that goes to the vacuum pump. starting to get annoyed with it now
Hi Ewanm you are not going to like this suggestion i know i would not! But i used to be on the tools as a mechanic up until 10 years ago and things have moved on so fast its worrying! My point is that you may be better off cutting your losses and going to a main dealer if you have one near you? One of the big ones if possible owned directly by Citroen.

The reason i suggest this is it sounds like you know what you are doing and will not of missed anything obvious. This would leave anyone with your fault in the dilemma you are in. The fault you describe is very often down to the egr valve so it was the first point of call, however look to see if the egr vacuum pipe goes into a small electro nematic valve down the back of the engine as these are known to play up. Otherwise unless someone comes along who has come across you problem and is willing to share the information (remember people who make a living out fixing these things very often wont let you in on their knowledge) you will just end up swopping components until you get lucky - very costly!

What ever you end up doing please let us all know how you get on and what ended up being your problem - this at least may help other people - see my injector problem posts.  All the best

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Last Post:malgpz900
Today 01:33 PM
» Replies: 1
» Views: 18
Heater Matrix replacement...
Last Post:noworries81
Today 01:13 PM
» Replies: 22
» Views: 3702
Black Smoke
Last Post:old son
Today 10:59 AM
» Replies: 4
» Views: 116
2012 berlingo radio setti...
Last Post:doofer
Today 10:58 AM
» Replies: 11
» Views: 233
New Battery
Last Post:doofer
Today 10:56 AM
» Replies: 5
» Views: 97
Cruise control possible o...
Last Post:brajomobil
Today 10:09 AM
» Replies: 2
» Views: 103
Berlingo VTR to ''XTR'' l...
Today 09:52 AM
» Replies: 6
» Views: 265
Strange exhaust blowing n...
Last Post:ffrenchie
Today 08:53 AM
» Replies: 2
» Views: 68
P1351 fault code.
Last Post:Boxer
Today 07:27 AM
» Replies: 16
» Views: 850
Lexia Scanner?
Last Post:brajomobil
Today 06:44 AM
» Replies: 1
» Views: 81

Locations of visitors to this page