Thread Rating:
  • 12 Vote(s) - 3.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
van keeps dying any advice greatly appreciated
#1
I have an 03 1.9 berlingo 120000 miles on the clock, was driving to work the other day and all of a sudden she just died no warning lights or anything,had plenty of fuel in her, but battery was dead.

Put on a new battery fired up straight away, but 10 minutes down the road she died again with a flat battery, again no warning lights or smoke etc.

Towed her home and put a multimeter on terminals (with a charged battery) getting 12.5v not started and 14.2v when started.

when running if I put the window de-icer on can hear the strain on engine, but 14.2v leads me to believe the alternator is fine?

Im completley baffled and have tried 3 seperate batterys

Help before i put her out of her misery
Reply
#2
Get someone to test the alternator properly, also check for a bad earth.
Somedays you're the pigeon, Somedays you're the statue.
Reply
#3
Im new here, thanks for your advice.
Will check earth, might just fit a 2nd hand alternator as there is one local on ebay for £20.
Must be the alternator as I cant see any other cause
Reply
#4
if the van won't run with a flat battery, there's evidently not enough leccy coming from the alternator.
Somedays you're the pigeon, Somedays you're the statue.
Reply
#5
(03-09-2011, 05:38 PM)steve valentine Wrote:  if the van won't run with a flat battery, there's evidently not enough leccy coming from the alternator.

are there any write ups etc on here?
im on a jeep forum too as thats what i drive out of work and has plenty of write ups etc, obviously a piece of pizz to change but nice to have a read up incase any tool needed that i dont have.

need to sort me van as a 4 litre jeep for a 100 mile a day work aint working
Reply
#6
Replacement of alternator needed.
Reply
#7
does the ecu play a part here?
Reply
#8
No. It's independend sourse. It controls by belt and voltage regulator
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Reverse light switch prob...
Last Post:Sootyfoot
Today 04:33 PM
» Replies: 10
» Views: 214
HELP! Smashed passenger w...
Last Post:Sootyfoot
Today 04:31 PM
» Replies: 2
» Views: 48
Diagnostic "gear" / Softw...
Last Post:cancunia
Today 04:19 PM
» Replies: 15
» Views: 586
Poor cold startup 1.9
Last Post:Top drive
Today 02:01 PM
» Replies: 38
» Views: 1011
Berlingo Parts
Last Post:malgpz900
Today 10:20 AM
» Replies: 1
» Views: 72
XTR heater control bulb r...
Last Post:Opensauce
Today 09:19 AM
» Replies: 1
» Views: 78
Trip Computer on Type A M...
Last Post:cancunia
Today 09:18 AM
» Replies: 1
» Views: 60
DW8 engine tapping
Last Post:jj9
Today 01:14 AM
» Replies: 3
» Views: 111
Rear window heater repair
Last Post:Silverberlingo
Yesterday 11:38 PM
» Replies: 0
» Views: 52
New PureTech 110 S&S Flai...
Last Post:Jed Clampit
Yesterday 09:04 PM
» Replies: 3
» Views: 89

Locations of visitors to this page