Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Mystery Connector. Airbag??
            Hi All,
First post here. Recently inherited a 1.4 2008 Berlingo. Looking for some wisdom…
Got the Heater Matrix replaced last week by local mech, came back with Airbag Light on. Stripped it down & airbag connector seems not to be connected, but does not seem to fit right in only place I can see that it should go. Auto – Electrician had a very quick look at it on Friday & said the same, he did not want to force it in.
Am I missing something here?? I don’t want to force the connection, hook back up the battery & have an airbag go off…..

Pictures should be below of connector.
Hi Daviie,

If the connector doesn't fit then its not meant to fit there, don't force it and just ignore it !

There have been some recent posts about a mystery connector which doesn't fit anything near the steering column, they look like your one.
 The consensus was it was for something that is not fitted to the berlingos in question.

The airbag light on is usually caused by the connector under the seat being disturbed and not always fitting right after reconnecting.  The driver/passenger seats may have been removed for access to the underdash areas.  Check that connector first.
That connector looks like the same type of connector I had in the back of my stereo in my previous Bipper. It may be for a remote stereo stalk.

Sent from my iPhone using Tapatalk
2015 1.6 L1850 90ps In Artic Steel inc Look Pack and Lighting Pack.
Sound. Cheers for the replies. I'll post up if the auto-electrician can definitively say what exactly it's for once he has another look at it.
I can assume that these two wires are for ignition lock (3V BE)

(see attach)

Attached Files Thumbnail(s)
(01-11-2015, 09:01 PM)pk7478 Wrote:  I can assume that these two wires are for ignition lock (3V BE)

(see attach)

Thanks. Running perfect at moment with them disconnected so not too important anyway.

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Help Surging/loosing powe...
Last Post:michaelg
Today 01:55 AM
» Replies: 5
» Views: 40
Roof bars for VTR?
Last Post:jimss
Today 12:39 AM
» Replies: 7
» Views: 156
Lack of power Then surge ...
Last Post:michaelg
Yesterday 10:34 PM
» Replies: 6
» Views: 210
something new
Last Post:Matt Haigh
Yesterday 10:26 PM
» Replies: 1
» Views: 49
Last Post:ntm1275
Yesterday 09:51 PM
» Replies: 2
» Views: 71
Last Post:ron
Yesterday 07:46 PM
» Replies: 6
» Views: 149
Poor fuel economy.. again...
Last Post:Jane Rushby
Yesterday 06:50 PM
» Replies: 13
» Views: 1419
Where Did you find
Last Post:Jane Rushby
Yesterday 06:26 PM
» Replies: 93
» Views: 165504
Radio needs VIN programme
Last Post:Tomcat3
Yesterday 06:09 PM
» Replies: 3
» Views: 137
Speedo/milometer fault
Last Post:Gixxerguyk8
Yesterday 04:51 PM
» Replies: 10
» Views: 908

Locations of visitors to this page