Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Replacement Key
My 2010 diesel MPV would not start. Everything else worked but it would not fire. The RAC suggested it was the chip in the key?? It sounds like I need a new key. Can I buy any key from eBay that is for use in a Berlingo? How do I code it? Presumably my local lock shop can cut the blank. Thanks
No a second hand key will not work first you need to find out first if it is the key, you need someone with citroen/Peugeot software to check it. Or find yourself an auto locksmith in your area and they can produce and code a new key for you.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
[+] 1 user says Thank You to Tomcat3 for this post
I take it you do not have the 2nd key or the key card that came with the car when new? Are there any warning lights on the dash when it is cranked, as TC says above, see what any fault codes say, it could be something completely different to the key.
MkIII VTR 1.6hdi Modutop, Climate Pack, 16" Alloys
I do not have the 2nd key or the key card. When I turn on the ignition I get 'Anti-theft Faulty' After the remote was switched on and off loads of times, just before the RAC arrived I turned the ignition and the fault code was gone and the engine started.
Could be the aerial on the ignition barrel, loose itself or loose electrical connection. Having the ignition key on a bunch with other keys or metal fob can also cause problems.

It sounds like your key is ok, so a good car locksmith should be able to clone it.
MkIII VTR 1.6hdi Modutop, Climate Pack, 16" Alloys
Thanks. The fob is on its own on the key ring. This has only happened twice in 8 months of ownership. Based on the above, is it still worth me getting a locksmith to take a look?
You may have been parked near something that was interfering with the signal or as solent says could be the sensor ring around the column playing up or its connections. If it was me I would be getting a spare just in case I lost the only key as then you will be in big trouble. I think Timpsons are able to do basic programmed keys and remote programmed keys fairly reasonable. Try a local auto locksmith for a price.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
I went to my local Timpson's and they quoted £55 for a basic key with chip. They tried to program the new chip but after putting my original key in their reader my key showed the 'Immobiliser Faulty' code. The new chip was therefore not copying anything and eventually they gave up.

Now when I put my original key in the ignition I get the fault code. I turn off and turn on and so far it has worked. Sounds like my issue has just got worse.

What do we reckon the next step might be?
hi. i would first get the car security pin, usually 4 digits..code for your car, this is what you need, you cannot program any keys without it..........there are virgin keys on about £21........ ebay.......take it to timpson's with pin code. or use diagbox to program keys..........should solve your problem........if its your key......
Take the cowl off the column and check the connections plug on the immobilizer ring then you really need to get it checked using diagbox software to see if its the key or immobilizer. Auto locksmiths have the equipment or you could try an independent citroen Peugeot garage or get the software yourself. There are members on here that have it and willing to help you. Also look on frenchcarforum as they have a list of members willing to help with software diagnostics.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Help Surging/loosing powe...
Last Post:michaelg
Yesterday 11:30 PM
» Replies: 4
» Views: 30
Lack of power Then surge ...
Last Post:michaelg
Yesterday 10:34 PM
» Replies: 6
» Views: 204
something new
Last Post:Matt Haigh
Yesterday 10:26 PM
» Replies: 1
» Views: 46
Last Post:ntm1275
Yesterday 09:51 PM
» Replies: 2
» Views: 68
Last Post:ron
Yesterday 07:46 PM
» Replies: 6
» Views: 146
Poor fuel economy.. again...
Last Post:Jane Rushby
Yesterday 06:50 PM
» Replies: 13
» Views: 1412
Where Did you find
Last Post:Jane Rushby
Yesterday 06:26 PM
» Replies: 93
» Views: 165498
Radio needs VIN programme
Last Post:Tomcat3
Yesterday 06:09 PM
» Replies: 3
» Views: 137
Speedo/milometer fault
Last Post:Gixxerguyk8
Yesterday 04:51 PM
» Replies: 10
» Views: 908
Rear reversing sensors
Last Post:tarrymittens
Yesterday 03:55 PM
» Replies: 0
» Views: 38

Locations of visitors to this page