Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Wipers got jammed
#1
Hi everybody

Have Mk1 2002 Berlingo panelvan. Today wiper blades got jammed. Now I have the following problems:

Wipers only 1 speed on all 3 settings
Window washer don't work
Glow light icon not lit on ignition on.

The engine start and run just fine and fuses seem to be OK. Any ideas ....... anybody?
Reply
#2
Check your fuses?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Berlingo won't start 2009...
Last Post:Chri5
Today 12:22 AM
» Replies: 7
» Views: 170
Insurance!
Last Post:fcamp
Yesterday 10:52 PM
» Replies: 6
» Views: 825
citroen berlingo desire 1...
Last Post:sks01773
Yesterday 10:47 PM
» Replies: 2
» Views: 40
1.6 16v petrol cambelt
Last Post:sks01773
Yesterday 10:40 PM
» Replies: 0
» Views: 20
B9 DPF Tank Top-Up
Last Post:Lighty
Yesterday 10:06 PM
» Replies: 5
» Views: 113
Rear light Cluster
Last Post:Peter Guy
Yesterday 09:57 PM
» Replies: 2
» Views: 31
2012 enterprise berlingo ...
Last Post:CourierJim
Yesterday 09:03 PM
» Replies: 6
» Views: 119
Head gasket failure.
Last Post:Civvic
Yesterday 08:08 PM
» Replies: 13
» Views: 361
At last
Last Post:Gerald Bostock
Yesterday 08:06 PM
» Replies: 9
» Views: 330
Conversion from manual to...
Last Post:Civvic
Yesterday 07:58 PM
» Replies: 1
» Views: 89

Locations of visitors to this page