Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Steering & Suspension] Strange spring in rear suspension?
I'm  working on replacing most of the rear brake system when I noticed a spring.
It's about 1" diameter, 2mm thick wire, about 3" long, and broken at one end...
It's mounted just next to the 'inner' end of the righthan brake hose. 

Sorry, no pictures at the moment. My cell-phone is rather shitty, and my camera is hiding somewhere.

So, anyone knows what it's for, what it's called and where I can find a new one?

As for the brakes...
(Since some probably are too curious for their own good)

Started with broken handbrake... 
When I removed the centre console, I found the tensioner wound all the way towards the handle, but still not able to handle the slack of the wires. 
So I ordered a set of wires and new brake shoes. Those arrived on monday. (Read: had hoped to use last weekend to mess about) 
On wednesday and thursday I had a couple of days off, so started early on wednesday(well, bout 10am... early for me)
Brake drums came off with the help of a pry bar and the 'persuader' (1Kg hammer) 
The drums were rusty, of course, and there was a lip around the rim, but that came off with a bit of 'persuasion' so they were OK.
(Used rust remover, then painted with a black 'engine paint' ) 
The silly pins and springs on the shoes... didn't go ping on the left side because the springs were loose already...
The arm on the shoes that the handbrake cables attach to... Rusted to heck and stuck. 
One shoe was worn down to about 0.5mm lining, which had partially broken off.  (Ouch!)
Cleaned it up as best I could, using quite a lot of brake cleaner. 
Noticed that the cylinder on the left side looked a bit... not right. One piston was extended, the other not. 
Pushed on the one that was extended and heard 'gurgling' and the dirt slowly turned darker. 
Yeah, caput. 
Bus trip to town to buy parts (new cylinders and the mounting kit for the shoes) 
Got back home and started removing cylinders. 
The bolts holding them were easy enough... The effing nut holding the brake pipe.. no... 
Good night...
Early on thursday, bus again. Bought better tools... 
Nope... Not a chance of getting them off. 
Friday. Bought new pipes after work, also a pipe bender... 

Today I tried again. I even cut the end off the pipe where it met the hose. No, that end didn't budge either. But now I could at least remove the cylinders... 
On the lefthand side, the tube on the other end of the hose came off without too much bother, so I just need to replace the hose...
On the righthand side, I had to attack the end on the distributor block or whatever it is. 
(I need two hoses and a piece of pipe... Buying that on monday)
I had to remove the brackets holding the brake hoses, so took them inside to give them the rust treatment and probably to hit them with a pit of paint. 

Tomorrow I may remove the spare tire and give the holding frame a bit of a rust job, too. You know, since I happen to have the rust eater stuff and a nearly full can of spray paint...
The broken spring is the return spring for the load limiting valve , common thing for it to break, nasty job replacing it. Thevalve limits the amount of brake pressure to the rear brakes , the idea is if your lightly loaded the rear brakes wont lock up
So, a good idea to replace it a soon as possible, then...
Found this on on the Bay of E...
(I can't find it in the inventory of any of the Norwegian parts stores... )

Is it a good one?
That looks like it
Well, it doesn't look exactly like the old one...
(Besides not being rusted and broken, I mean.)
I have a suspicion that the original was rubbing against something and that this design stops that from happening.

I'm ordering it. Lets hope it doesn't take too long to arrive here.
Its a copy ,not original but it will do the job. Keep the old parts to get the measurements off it.

There is a sticker under the bonnet  that gives the settings for it but its a long complicated procedure. The sticker is on the drivers side near the suspension turret on mine (RH D).

Its easier just to set the new one with measurements from the old.
[+] 1 user says Thank You to brodfather11 for this post

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Black Smoke
Last Post:old son
Today 10:59 AM
» Replies: 4
» Views: 112
2012 berlingo radio setti...
Last Post:doofer
Today 10:58 AM
» Replies: 11
» Views: 228
New Battery
Last Post:doofer
Today 10:56 AM
» Replies: 5
» Views: 90
Cruise control possible o...
Last Post:brajomobil
Today 10:09 AM
» Replies: 2
» Views: 99
Berlingo VTR to ''XTR'' l...
Today 09:52 AM
» Replies: 6
» Views: 262
Strange exhaust blowing n...
Last Post:ffrenchie
Today 08:53 AM
» Replies: 2
» Views: 64
P1351 fault code.
Last Post:Boxer
Today 07:27 AM
» Replies: 16
» Views: 848
Lexia Scanner?
Last Post:brajomobil
Today 06:44 AM
» Replies: 1
» Views: 80
Dead BSI unit?
Last Post:brajomobil
Today 06:26 AM
» Replies: 3
» Views: 55
My Berlingo Camper build....
Last Post:Jed Clampit
Yesterday 09:58 PM
» Replies: 8
» Views: 372

Locations of visitors to this page