Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
2005 2.0 HDI BSI playing up.
After a long motorway run in the torrential rain, things have gone funny. Firstly the windscreen wipers wouldn't turn off, and then started operating randomly. Next the remote locking became temperamental. The dash warning lights started flashing, the fuel light and the STOP light are blinking, and the odometer wasn't displaying correctly. I removed the BSI and found it was wet. Dried it thoroughly and replaced, and followed the reset instructions, but no joy. Now whenever it wakes up, the front headlights come on, the dash lights come on, loads of warning lights, the odometer shows lines instead of numbers. I have left the battery disconnected over night and will try a reset again in the morning, but what are my chances? Nothing looks corroded.

Sent from my D6603 using Tapatalk
Connect Lexia and check faults.
No joy overnight. Another problem is I am currently about 200 miles from home, and only have a Bluetooth obd reader with me, and my phone. It connects to the ecu with no problems, and gives no faults recorded, but I don't think it cam read the BSI.
I've fixed it. The problem was, I had fitted led sidelight bulbs, swapped em out for bog standard, all fixed!
Well done for sorting it al, it's amazing how a small thing can cause havoc with the electrics on this car. I would suggest that when you know your BSI is really dry you try to find a way to waterproof it, just in case..

2012 Iron Grey XTR 110 with lots of bits and bobs.
[+] 1 user says Thank You to Trevor for this post
Spray it with fogging oil
And clear the windscreen scuttle out as it sounds like the drain holes are blocked and water is building up.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
Good to see you've got it sorted Smile were the led's non canbus you never think a led bulb would do that  Huh
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy

The leds were made by Ring, from Halfords. They worked fine until the BSI got wet. I think when the system is reset it wasn't seeing the right current draw from them. Im still having some little niggles, but she drives, so I can get home. Im going to get hold of a lexis and see what problems I might be having
Now I'm home and can have a proper look, I still have some fairly inconvenient faults. My front wipers do not work, although the rear and washer jets do. I have tried to reset the comm 2000 with no success. Fuse is fine. The handbrake light on the dash is not working, and occasionally the airbag warning lights, including the 1 with a "2" next to it are on. Does anybody know which plugs on the BSI come from the comm 2000 and go to the wipers?

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
M49 1.9 diesel misfire a...
Last Post:jj9
Today 12:29 PM
» Replies: 3
» Views: 79
splayed rear wheels
Last Post:Johny555
Today 10:39 AM
» Replies: 1
» Views: 24
I'm hearing better or smt...
Last Post:Luis Rosa
Today 10:16 AM
» Replies: 8
» Views: 271
Car smell...
Last Post:noidea0
Today 09:59 AM
» Replies: 0
» Views: 27
Is there a need to conver...
Last Post:noidea0
Today 09:41 AM
» Replies: 19
» Views: 925
Heater Matrix replacement...
Last Post:geoff
Today 07:48 AM
» Replies: 24
» Views: 3822
2006 1.6hdi - indicators ...
Last Post:geoff
Today 07:44 AM
» Replies: 14
» Views: 366
Checking how much DPF Add...
Last Post:ntm1275
Yesterday 11:40 PM
» Replies: 3
» Views: 83
Rear reversing sensors
Last Post:tarrymittens
Yesterday 10:01 PM
» Replies: 2
» Views: 130
Blingo Help Please
Last Post:jj9
Yesterday 09:30 PM
» Replies: 12
» Views: 1303

Locations of visitors to this page