Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Clock binnacle
#1
Could any 1 help me I have go a 2002 berlingo 1.9 d the Speedo,rev counter and temp gauge are no working but the fuel gauge is working the clock lights up when put lights on the mileage screen say 00000 I have just changed complete binnacle but still the same any help would be very much appreciated
Reply
#2
Hi,
It seems no one has had this problem before. I've haven't heard if it or a way of sorting it.
You could always try all the connections to earth, I think theres one behind the radio .
All the fuses are OK?. the ones in the engine compartment can be affected by water , don't know if it would affect the speedo etc, you can always check them.
Bsi box is behind the drivers side fuse box , check in case dampness has affected the connections .

There is a pair of electrical plug behind the battery , I think that they carry signals from the engine to the BSI etc, check that they are OK.

Somebody else may be by soon who knows something better about it than me
[+] 1 user says Thank You to brodfather11 for this post
Reply
#3
thanks very much pal I will let u no how I get on cheerz
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
New PureTech 110 S&S Flai...
Last Post:Jed Clampit
Today 09:04 PM
» Replies: 3
» Views: 49
What website to pass time...
Last Post:Solent
Today 08:32 PM
» Replies: 0
» Views: 21
Berlingo Parts
Last Post:Sb12
Today 07:56 PM
» Replies: 0
» Views: 25
Rear hub nut torque setti...
Last Post:jj9
Today 07:55 PM
» Replies: 15
» Views: 238
temperatue dial
Last Post:Kokain
Today 05:28 PM
» Replies: 3
» Views: 68
Trip Computer on Type A M...
Last Post:cancunia
Today 03:50 PM
» Replies: 0
» Views: 23
Loud beeping from radio u...
Last Post:nicko
Today 03:49 PM
» Replies: 3
» Views: 110
Ligts won't go off!
Last Post:Berlingos12
Today 02:50 PM
» Replies: 10
» Views: 468
DW8 engine tapping
Last Post:brodfather11
Today 08:30 AM
» Replies: 1
» Views: 74
Washers not working
Last Post:Luis Rosa
Today 07:47 AM
» Replies: 8
» Views: 229

Locations of visitors to this page