Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] non starter 1.6HDI 2007
#1
Hi guys,

My 2007 M59 1.6HDI has decided not to start today.   Occasionally for the last few weeks it would start fine but after say 15 seconds idling it would stop and then be difficult to restart although once started it ran fine.

I`ve got two error codes today
p1350 P1350 Fuel level sensor B Intermittent/Bypass line monitor / SID 801 - Pre/Post heating relay circuit - Short or Open circuit, including Pre-Heat plugs
p1351

wgich I believe are to do with glow plugs?     

Can anyone offer any help on this?


Many thanks,

Mark
Reply
#2
It would be unusual for defective glow plugs to cause a non start on the 1.6hdi - when the plugs are down it usually causes smoke at start up as the glow plugs help with emissions when the engine is cold.

When was the last time the fuel/air filters were replaced?

I would get a good set of glow plugs from say GSF and try that and let us all know how you got on.
Reply
#3
The fuel filter and air filters were done about 3000 miles ago. I`m pretty fastidious about such things. I have ran the fuel tank lower than normal a couple of times and I`m wondering if this has possibly clogged the filter.
after unscrewing the drain screw on the fuel filter today and pumping the primer the van eventually started. I`ve not got much confidence in it though

It doesn`t help that the rain / standing water and puddles of late are so bad and I`ve had to go through some deepish puddles recently too which I`d not normally do.....


I`ve been to ECP today and have a new Bosch fuel filter, Bosch heater plugs and heater plug relay. Not convinced i`ll do the glow plugs myself but i`ll def do the relay and fuel filter tomorrow .

M
Reply
#4
The fuel pick up could be clogged up like you say - this new bio mix diesel can cause it so it would not hurt the remove it if you can and check.

I think it was very telling that when you pumped the primer it started this could mean air is being drawn into the system - maybe the o rings on the fuel filter connectors?
Reply
#5
I`ll keep you posted
Reply
#6
New Bosch fuel filter fitted today. Primed.
Van fired up first time and kept running.

Hopefully that's it.

I'm guessing the running on fumes thing I had to do a week or so ago may well have pulled through some crap.

Time will tell!

M
Reply
#7
Sound always start with the basics lets hope its sorted it for you.
Reply
#8
Time for a refund on the plugs and relay then .....
Reply
#9
No I`m going to fit those as the glow plugs are definitely past it. Cheap enough so I`d rather know it`s right in that department.
Reply
#10
(30-12-2015, 12:45 AM)markyr2k1 Wrote:  No I`m going to fit those as the glow plugs are definitely past it.  Cheap enough so I`d rather know it`s right in that department.

Yes thats the sensible thing to do.I change mine every 2 years as i would spark plugs in a petrol engine,its strange how the resistance changes over time ,i guess thats the heat having some sort of effect which would almost certainly also have an effect on the "glow".Its also a fact that one or two plugs could fail and you wouldnt know anything about it so the cold start would become "inefficient" and sluggish.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Running on chip oil
Last Post:polar
Today 04:07 AM
» Replies: 1
» Views: 12
Poor cold startup 1.9
Last Post:Top drive
Today 12:24 AM
» Replies: 40
» Views: 1081
2004 Berlino Aerial
Last Post:brodfather11
Yesterday 10:48 PM
» Replies: 1
» Views: 35
Washers not working
Last Post:Lighty
Yesterday 09:09 PM
» Replies: 11
» Views: 304
Reverse light switch prob...
Last Post:Col
Yesterday 07:22 PM
» Replies: 12
» Views: 263
2005 2.0 HDI Siemens pump...
Last Post:Woodyrvf750
Yesterday 07:05 PM
» Replies: 0
» Views: 32
Fuse is burning all the t...
Last Post:fernandoblas
Yesterday 05:23 PM
» Replies: 12
» Views: 417
HELP! Smashed passenger w...
Last Post:Sootyfoot
Yesterday 04:31 PM
» Replies: 2
» Views: 74
Diagnostic "gear" / Softw...
Last Post:cancunia
Yesterday 04:19 PM
» Replies: 15
» Views: 619
Berlingo Parts
Last Post:malgpz900
Yesterday 10:20 AM
» Replies: 1
» Views: 91

Locations of visitors to this page