Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Warning Light] Alternator Warning Light
Howdy All,

Had months of trouble free life with my 2000 Partner 2.0 HDi. Yesterday, I fitted some new wheels and tyres (Citroen C5 Alloys with 195/65/15 on) and also gave it a rather intensive wash.

Now, this was all done at the same time, but since doing that (please note driving it in the morning with original wheels and tyres, it was fine), I now have an alternator warning light which came on yesterday evening, but after a turn of, turn on went away. Then today was on 80% of the time whilst running some favours. Kept the engine running the whole time just in case.

Couple of pointers:

1) Multimeter on battery after I got back was just under 12v engine off (it just done 2 hours or so driving around with light on and off). Engine running, it dropped to 11.2/3v. Turn it off again, it went back up.

2) Back running again, if I revved it's guts out when stationary, it seems like I could get the alternator to kick in, then it seemed to stay at the normal 14.3/5v.

3) Earlier when driving, it seemed like sometimes when I drove it hard and picked up the RPM, the light would go off, but pootling, it'd bring it back on again. Last 20 mins of journey it stayed on no matter what I did.

4) When I put the new wheels and tyres on, the front drivers side caught the plastic arch liner (it was loose) and yanked it up and out quite hard and stayed as such for 400 yards as I pulled into drive.

Am I looking at a dying alternator? The thing that's worrying me now is the arch liner. I've just read that some wiring runs under that arch from the BSI. This includes the alternator exciter wire. Everything else seems to be fine, but could the liner of damaged the wiring? Could I have damaged the BSI or the exciter wiring?

I've tried to hunt down a workshop manual / wiring diagram, but found nothing. Autodata doesn't have much on these either.

I'm yet to try hard wiring the exciter, but that will have to now be after work tomorrow (so long as the van can get me there!).

Any help appreciated!
Think the alternator is on the way out. If the wiring is broken, it wouldn't be intermittant.
Sounds like a duff battery. If the alternator is causing the engine to run hard, I'd be looking at the state of the battery especially if you are seeing sub 12v while the engine isn't running.

Sent from my iPhone using Tapatalk
2015 1.6 L1850 90ps In Artic Steel inc Look Pack and Lighting Pack.
I've not noticed the engine labouring to signify a harder working alternator. The sub 12v was after a good couple hours running with 80% of the time with the warning light on, so can only assume this was down to natural discharge?

If the exciter wire is damaged I'm wondering if the system might be picking up high resistance as the wire moves and shuffles. Is the exciter a single run from IGN to ALT? Or does this bypass the starter like many systems?
The exciter wire runs through the engine running relay . These relays can give a bit of bother with bad earths . They are mounted on the n/side inner wing.
Thanks! Have you a wiring diagram / colour code at all?

Would be good to trace it specidically!

Is there any validity in the arch liner being pulled causing any working issues?

Turned out the Voltage Regulator on the alternator was borked. Re-built by a guy who knows his stuff and told it should now outlast the van.

It's the original one to the van and never been worked on so he was very impressed (16 years and 155000 miles). The older alternators are far superior to anything these days. He said even Bosch/Valeo he only expects to see about 3 years.

Quality of components, especially the copper windings are horrendous now'a days!

Better to re-build your old stuff if it's fixable, than to get new ones!
^^^^ I'd would say that a rebuild can be a DIY proposition as in the main the brush / regulator packs are simple to fit unless the commutator is badly worn though often a general wear lip on the copper can be dressed down with a sharp file with some satisfaction and accuracy. I did a dynamo like this the other day and the " boys " alternator around two years and 30k miles ago,still going strong.

Confidence issues ? Should be all you need on Google / youtube .................................
If I had the time I'd of happily done it myself. I had to get it tested and re-built in a couple hours from breaking down to fixed so not the time to test and wait on parts.
You got a " result " which is the main thing.

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Bump and Run - Am I right...
Last Post:polar
Today 05:47 PM
» Replies: 6
» Views: 80
replacing diesel fuel pip...
Last Post:geoff
Today 05:13 PM
» Replies: 35
» Views: 1997
2004 2.0HDi Cruise Contro...
Last Post:cancunia
Today 04:57 PM
» Replies: 0
» Views: 18
M49 1.9 diesel misfire a...
Last Post:jj9
Today 12:29 PM
» Replies: 3
» Views: 102
splayed rear wheels
Last Post:Johny555
Today 10:39 AM
» Replies: 1
» Views: 45
I'm hearing better or smt...
Last Post:Luis Rosa
Today 10:16 AM
» Replies: 8
» Views: 295
Car smell...
Last Post:noidea0
Today 09:59 AM
» Replies: 0
» Views: 47
Is there a need to conver...
Last Post:noidea0
Today 09:41 AM
» Replies: 19
» Views: 958
Heater Matrix replacement...
Last Post:geoff
Today 07:48 AM
» Replies: 24
» Views: 3845
2006 1.6hdi - indicators ...
Last Post:geoff
Today 07:44 AM
» Replies: 14
» Views: 375

Locations of visitors to this page