Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] Anti Pollution Faulty - Injector 1
Hi all,

While driving around xmas, my 2009 Berlingo 1.6HDi cut out a number of times with the engine management light coming on and the 'Anti Pollution faulty' message coming up on the screen. After a while it went off and the van drove perfectly until last Friday when it came back on and the whole 40 mile drive from my gfs house the van was in limp mode, losing power on hills, not going above 2,500rpm and basically driving (and sounding) like a dog.

First I brought it to a local mechanic who put it on his diagnostic machine and it came back saying Fault with Injector 1 (didn't get a fault code). He tried turning off the fault but kept shooting straight back up.

So I brought it to my mechanic friend who sold me the van and who told me had put 2 new injectors in it 6 months ago. He had them tested and they are all perfect. Checked the wiring also and that's all fine.

So is there any other way a fault reader could show up an injector issue but the injector itself not be at fault?

Is there anything else I could have checked? At the moment he is cleaning out the fuel tank, putting some fuel in and trying that out.

Thanks in advance!
Could well be the out put from the Ecu. We have experienced a few cars , where water has got into the Ecu plug and caused the misfire . No1 cylinder on the Berlingo , in fact any PSA car is at the gearbox end, just I case you didn't know.
When mine had those symptoms it was failed erg valve. Probably most cost effective way to sort it is take it to Citroen garage to diagnose with Lexia.

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Eco activated but engine ...
Last Post:doofer
Today 04:03 PM
» Replies: 16
» Views: 358
Still on the elusive 4x10...
Last Post:doofer
Today 03:03 PM
» Replies: 1
» Views: 57
Berlingo VTR to ''XTR'' l...
Last Post:doofer
Today 12:58 PM
» Replies: 4
» Views: 185
cooling fans
Last Post:blueiceplus
Today 12:57 PM
» Replies: 0
» Views: 17
OBD Eror Code P1351
Last Post:PeteK
Today 11:11 AM
» Replies: 5
» Views: 142
font fog light bulb chang...
Last Post:rdfb2
Today 10:27 AM
» Replies: 3
» Views: 86
Last Post:my mucker
Today 10:17 AM
» Replies: 2
» Views: 99
Cruise control possible o...
Last Post:cancunia
Today 09:43 AM
» Replies: 1
» Views: 53
Front camber out of align...
Last Post:Civvic
Today 09:21 AM
» Replies: 4
» Views: 72
How the heck do I remove ...
Last Post:CourierJim
Yesterday 11:20 PM
» Replies: 6
» Views: 569

Locations of visitors to this page