Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
2009 1.6 Hdi Berlingo (Intercooler Query)
#1
Just a query, I've recently purchased the above mentioned (Old Shape) and with a slight knock to the front drivers corner (Still Driving) but there is some damage to the intercooler. It doesn't look like it is busted but it has a small squeeze on the side, should this make any difference or would it need to be replaced??
Reply
#2
Any chance of a photograph ?

edit : Well it won't leak fluid so unless punctured then tally ho and keep the cash in your wallet........
Reply
#3
Thanks, I took it out when straightening the front and had a quick look at it and it didn't look like it is punctured, but didn't really take too much notice. It's now put back in so can't get a photo but I was wondering afterward, what if it was punctured??

There was one other strange thing that happened when it all went back together, that has led me to think about the whole set up, the van runs and drives great but when the engine is switched off there is a wirring noise from the turbo area that runs on for several minutes. It sounds like the turbo blades are still spinning and take some time to stop??

Any idea on this or is it a puncture in the intercooler that is causing this??
Reply
#4
its probably the sound of your fuel pump shutting down
2015 1.6 L1850 90ps In Artic Steel inc Look Pack and Lighting Pack.
Reply
#5
But something must be wrong since it takes 5 minutes for what ever it is to shut down, I've even taken the lead of the battery disconnecting the power but it still goes on for ages???
Reply
#6
Can you upload a sound clip or video to YouTube or something? It's difficult to say just by written word


Sent from my iPhone using Tapatalk
2015 1.6 L1850 90ps In Artic Steel inc Look Pack and Lighting Pack.
Reply
#7
I can't get my wee vid to upload to Photo Bucket from this phone, dam I-phones. As soon as I get to a computer I'll get it posted. Thanks...
Reply
#8
[Image: th_trim.A466A62F-5CBB-4771-B3FE-3C422660...heqejk.mp4]
Reply
#9
I give up, will try again later. ???
Reply
#10
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
New PureTech 110 S&S Flai...
Last Post:Jed Clampit
Today 09:04 PM
» Replies: 3
» Views: 43
What website to pass time...
Last Post:Solent
Today 08:32 PM
» Replies: 0
» Views: 14
Berlingo Parts
Last Post:Sb12
Today 07:56 PM
» Replies: 0
» Views: 18
Rear hub nut torque setti...
Last Post:jj9
Today 07:55 PM
» Replies: 15
» Views: 229
temperatue dial
Last Post:Kokain
Today 05:28 PM
» Replies: 3
» Views: 65
Trip Computer on Type A M...
Last Post:cancunia
Today 03:50 PM
» Replies: 0
» Views: 22
Loud beeping from radio u...
Last Post:nicko
Today 03:49 PM
» Replies: 3
» Views: 106
Ligts won't go off!
Last Post:Berlingos12
Today 02:50 PM
» Replies: 10
» Views: 467
DW8 engine tapping
Last Post:brodfather11
Today 08:30 AM
» Replies: 1
» Views: 73
Washers not working
Last Post:Luis Rosa
Today 07:47 AM
» Replies: 8
» Views: 229

Locations of visitors to this page