Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Diesel Injector Leak
#1
Hi all,
I've purchased my first time 1.6 hdi Citroen Berlingo 2008 few months ago. I've recently noticed diesel leak from the injectors.

Can any one advise please?

Many thanks to you all.
Reply
#2
HI Minewash you need to read this thread http://www.berlingoforum.co.uk/thread-4638.html
Reply
#3
[attachment=2796 Wrote:polar pid='84709' dateline='1456907028']HI Minewash you need to read this thread http://www.berlingoforum.co.uk/thread-4638.html

Thank you polar. I've already checked the injector bolts and got them secured, but the diesel leak still exists.

A little bit about the history of the problem:

First the car started discharging huge amounts of black smoke and the engine had a strange noise. I got the car checked by computer where the technician advised me to change the injectors which were faulty. I got the injectors changed by used ones in a good situation, and every thing was good for a while, then there was oil leak, the mechanic changed the rubber seal (part c in the attached picture)for the injectors, but this did not work. Another mechanic has removed the top cover of the engine and got it sealed using a special paste. The oil leak stopped, and then started the diesel leak!

I just wanted to say that two injectors lack the plastic washer (part B in the attached picture)     under the top of the injectors, the mechanic said that this does not harm by any means.

Can you please advise after giving above details?
Reply
#4
Hi Minewash i see so you have no oil or smoke coming from the injectors now but just a diesel leak?

I seem to remember someone on this forum having the same problem and the cure was to replace the seals both parts B and C

Try doing a search i dont have my manual at hand at the moment but and ive never done the job so i hope someone comes along who has for you.

I do have a Picasso Manual and it does have the 1.6 hdi engine in it so when i lay my hands on it ill have a look see.
Reply
#5
(02-03-2016, 05:09 PM)polar Wrote:  Hi Minewash i see so you have no oil or smoke coming from the injectors now but just a diesel leak?

I seem to remember someone on this forum having the same problem and the cure was to replace the seals both parts B and C

Try doing a search i dont have my manual at hand at the moment but and ive never done the job so i hope someone comes along who has for you.

I do have a Picasso Manual and it does have the 1.6 hdi engine in it so when i lay my hands on it ill have a look see.
Thank you very much polar. You are amazing. Thanks a million.  I will try it and keep you updated.
Reply
#6
(02-03-2016, 05:52 PM)Minewash Wrote:  
(02-03-2016, 05:09 PM)polar Wrote:  Hi Minewash i see so you have no oil or smoke coming from the injectors now but just a diesel leak?

I seem to remember someone on this forum having the same problem and the cure was to replace the seals both parts B and C

Try doing a search i dont have my manual at hand at the moment but and ive never done the job so i hope someone comes along who has for you.

I do have a Picasso Manual and it does have the 1.6 hdi engine in it so when i lay my hands on it ill have a look see.
Thank you very much polar. You are amazing. Thanks a million.  I will try it and keep you updated.

Hi Polar and all. I just wanted to say that someone has advised me to change the O ring rather than the parts B and C claiming that replacing the B and C parts can stop oil leaking rather than diesel! Please advise
Reply
#7
Im not sure minewash and i still havent managed to get to my manual yet but i will be able to have a look on Sunday if that is any good to you?

However i would replace all the seals and washers on the affected injectors
Reply
#8
(04-03-2016, 08:45 PM)polar Wrote:  Im not sure minewash and i still havent managed to get to my manual yet but i will be able to have a look on Sunday if that is any good to you?

However i would replace all the seals and washers on the affected injectors
Reply
#9
(05-03-2016, 06:59 AM)Minewash Wrote:  
(04-03-2016, 08:45 PM)polar Wrote:  Im not sure minewash and i still havent managed to get to my manual yet but i will be able to have a look on Sunday if that is any good to you?

However i would replace all the seals and washers on the affected injectors

Hi Polar. Great, that always will be good. Its always good to know and accumulate experience to benefit myself and other people.

By the way: I just followed your previous advice and got the seals, both parts B&C changed for all injectors, and I'll also keep you updated.

Thanks a million.
Reply
#10
(05-03-2016, 07:02 AM)Minewash Wrote:  
(05-03-2016, 06:59 AM)Minewash Wrote:  
(04-03-2016, 08:45 PM)polar Wrote:  Im not sure minewash and i still havent managed to get to my manual yet but i will be able to have a look on Sunday if that is any good to you?

However i would replace all the seals and washers on the affected injectors

Hi Polar. Great, that always will be good. Its always good to know and accumulate experience to benefit myself and other people.

By the way: I just followed your previous advice and got the seals, both parts B&C changed for all injectors, and I'll also keep you updated.


Thanks a million.

Hi Minewash ive had a look at my manual and it does not give that much information but it does show the upper o ring and bottom copper fire seal. As i suspected it just says all the seals should be replaced.

What i have found is a number of injectors loose on the 1.6hdi's and the recommended torque on the injector nuts to be to low IMO so i would not torque them as tight as you dare without snapping anything. 

Needless to say if they have been blowing/leaking i would also do an engine oil flush the clean out any carbon deposits.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Running on chip oil
Last Post:polar
Today 04:07 AM
» Replies: 1
» Views: 12
Poor cold startup 1.9
Last Post:Top drive
Today 12:24 AM
» Replies: 40
» Views: 1081
2004 Berlino Aerial
Last Post:brodfather11
Yesterday 10:48 PM
» Replies: 1
» Views: 35
Washers not working
Last Post:Lighty
Yesterday 09:09 PM
» Replies: 11
» Views: 304
Reverse light switch prob...
Last Post:Col
Yesterday 07:22 PM
» Replies: 12
» Views: 263
2005 2.0 HDI Siemens pump...
Last Post:Woodyrvf750
Yesterday 07:05 PM
» Replies: 0
» Views: 32
Fuse is burning all the t...
Last Post:fernandoblas
Yesterday 05:23 PM
» Replies: 12
» Views: 417
HELP! Smashed passenger w...
Last Post:Sootyfoot
Yesterday 04:31 PM
» Replies: 2
» Views: 74
Diagnostic "gear" / Softw...
Last Post:cancunia
Yesterday 04:19 PM
» Replies: 15
» Views: 619
Berlingo Parts
Last Post:malgpz900
Yesterday 10:20 AM
» Replies: 1
» Views: 91

Locations of visitors to this page