Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Electrical Issue (Partner)
#1
Hi,

I have a 2003 1.9 Partner and recently the battery light has started to come on whilst driving (not all the time tho), sometimes it just turns off again but it always turns off when the engine is restarted.

I have checked the voltage whilst idling/revving and all appears ok which leads me to believe the alternator is fine. The van has never had an issue starting tho.

There is a single small wire which goes onto the alternator (guessing for the sensor) and this seemed pretty corroded so replaced the connector but this doesn't seem to have made any difference.

There are a couple of other issues but I not sure if they are related or not, the horn only works with the ignition off and when the battery light comes on the stereo (aftermarket) switches off.

The rest of the electrics appear fine tho!

If anyone has any ideas I would be grateful.
Reply
#2
Hi burtross your horn issue is probably the earth on the steering wheel under the airbag. Ive had to do both of my berlingos to sort it. There is a thread on here with pictures to show you how to do it have a search. Here you go http://www.berlingoforum.co.uk/thread-36...l#pid26651 have a look at post 12. Thanks to Geoff for the post. As for the other faults start with the basics check battery is good and good connections, same with alternator check contacts/wiring and output. You should be getting about 14 volts when engine running Check earth leads from battery and engine to chassis.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Ligts won't go off!
Last Post:Berlingos12
Today 02:50 PM
» Replies: 10
» Views: 427
Rear hub nut torque setti...
Last Post:cancunia
Today 01:47 PM
» Replies: 13
» Views: 184
temperatue dial
Last Post:polar
Today 11:47 AM
» Replies: 1
» Views: 25
Loud beeping from radio u...
Last Post:Tree
Today 08:35 AM
» Replies: 2
» Views: 69
DW8 engine tapping
Last Post:brodfather11
Today 08:30 AM
» Replies: 1
» Views: 52
Washers not working
Last Post:Luis Rosa
Today 07:47 AM
» Replies: 8
» Views: 215
increase in a ratchet-typ...
Last Post:saskak
Today 12:36 AM
» Replies: 7
» Views: 145
Rear Wiper Motor
Last Post:madwelshman
Yesterday 10:42 PM
» Replies: 3
» Views: 123
Heater control unit/resis...
Last Post:mreid63
Yesterday 10:34 PM
» Replies: 5
» Views: 348
Facial light replacement
Last Post:Mike
Yesterday 09:23 PM
» Replies: 11
» Views: 306

Locations of visitors to this page