Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] Rev counter
#1
Quite a complex problem .. So here goes!
We changed an engine (1.9 ) on a Berlingo.Replaced the three wire pump solenoid with a single wire solenoid.
I now have no rev counter & a battery light on the dash.
The van will then go into Eco mode after 10mins ( lose dashboard, headlights etc) as I assume it thinks the engine isn't running.
The signal wire coming from the alternator has continuity up to the ecu.
Battery/ alternator is charging at 14.4 v -normal
I have changed the crank sensor
Does the Rev counter pick up from the crank sensor?
Anyone have any ideas to a very specific problem!
Possible ecu fault but it didn't have this problem before we changed the engine!
Reply
#2
(13-03-2016, 08:34 PM)Nik Buck Wrote:  Quite a complex problem .. So here goes!
We changed an engine (1.9 ) on a Berlingo.Replaced the three wire pump solenoid with a single wire solenoid.
I now have no rev counter & a battery light on the dash.
The van will then go into Eco mode after 10mins ( lose dashboard, headlights etc) as I assume it thinks the engine isn't running.
The signal wire coming from the alternator has continuity up to the ecu.
Battery/ alternator is charging at 14.4 v -normal
I have changed the crank sensor
Does the Rev counter pick up from the crank sensor?
Anyone have any ideas to a very specific problem!
Possible ecu fault but it didn't have this problem before we changed the engine!

It wold be best to connect the car to some diagnostic and see if diagnostic is showing revs.
That would exclude dash... 

Best regards,
brajomobil
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Poor cold startup 1.9
Last Post:jj9
Yesterday 11:57 PM
» Replies: 39
» Views: 1050
2004 Berlino Aerial
Last Post:brodfather11
Yesterday 10:48 PM
» Replies: 1
» Views: 29
Washers not working
Last Post:Lighty
Yesterday 09:09 PM
» Replies: 11
» Views: 301
Reverse light switch prob...
Last Post:Col
Yesterday 07:22 PM
» Replies: 12
» Views: 254
2005 2.0 HDI Siemens pump...
Last Post:Woodyrvf750
Yesterday 07:05 PM
» Replies: 0
» Views: 28
Fuse is burning all the t...
Last Post:fernandoblas
Yesterday 05:23 PM
» Replies: 12
» Views: 415
HELP! Smashed passenger w...
Last Post:Sootyfoot
Yesterday 04:31 PM
» Replies: 2
» Views: 71
Diagnostic "gear" / Softw...
Last Post:cancunia
Yesterday 04:19 PM
» Replies: 15
» Views: 619
Berlingo Parts
Last Post:malgpz900
Yesterday 10:20 AM
» Replies: 1
» Views: 90
XTR heater control bulb r...
Last Post:Opensauce
Yesterday 09:19 AM
» Replies: 1
» Views: 85

Locations of visitors to this page