Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] 1.9d starting/running isses - pump duff??
Morning all,
I'm still trying to get my wifes 1.9d (03 plate) to run.   I've put in a known good engine having had an issue starting/running on the old engine which was damaged (slipped belt)... but the pump on the replacement was obviously not coded to the car so I transferred the pump from the old engine.   The car will start (sometimes - normally if you "twitch" the key rather than make it turn over for longer) but will only tick over (not rev) when started (stutters/smoked at about 1500rpm).  Starting is as stated very difficult too.   The cars reporting no fault codes.  The "pump" to prime the fuel system is stiff and I cant see any bubbles in the clear pipe.   If I disconnect the return pipe and pump it comes out without bubbles too (clear pipe into bottle).
New glow plugs.  Checked and they are working.
I thought it was timing so I've checked and rechecked the belt/timing holes line up.  I cant figure out how to advance/retard the timing on the pump... it has no slots for rotating the pump on the mount at the front (it does have a slotted rear mount though)?   It's the lucus Delphi pump with the electronic advance/retard).

The only odd other symptom is the relay behind the battery box (underneath the ECU) is clicking like crazy each time the engine dies after ticking over for a 30 seconds/a minute or so.  I'm thinking this is the glow plug relay?? Or could it be the fuel relay.. if so why would it click?

Other thought is that the pump itself is duff...   I really don't want to spend any more cash on the car (it's simply not worth it).. And I have the pump from the engine that I've put in which I know ran fine...  Is there any way of de-coding/bypassing the code on a pump??

Any thoughts received with thanks...  I'm giving the old girl one last weekend of work before I throw in the towel.  Would be shame to break her up but we already have a replacement/stand in car so unless I can figure it out myself without spending any more Wonga she's destined to be broken up to try and get the engine cost back at least.

Cheers Jim
Don't know about the other problems,but I think glow plug relay is behind head light nr side. that's were mine is,but mines 2L may be diffrent
You can get rid of the immobiliser from the fuel pump but its not very easy to do

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Bump and Run - Am I right...
Last Post:MarkT
Today 02:37 PM
» Replies: 3
» Views: 42
replacing diesel fuel pip...
Last Post:kigs66
Today 01:12 PM
» Replies: 33
» Views: 1956
M49 1.9 diesel misfire a...
Last Post:jj9
Today 12:29 PM
» Replies: 3
» Views: 94
splayed rear wheels
Last Post:Johny555
Today 10:39 AM
» Replies: 1
» Views: 33
I'm hearing better or smt...
Last Post:Luis Rosa
Today 10:16 AM
» Replies: 8
» Views: 286
Car smell...
Last Post:noidea0
Today 09:59 AM
» Replies: 0
» Views: 39
Is there a need to conver...
Last Post:noidea0
Today 09:41 AM
» Replies: 19
» Views: 943
Heater Matrix replacement...
Last Post:geoff
Today 07:48 AM
» Replies: 24
» Views: 3833
2006 1.6hdi - indicators ...
Last Post:geoff
Today 07:44 AM
» Replies: 14
» Views: 372
Checking how much DPF Add...
Last Post:ntm1275
Yesterday 11:40 PM
» Replies: 3
» Views: 89

Locations of visitors to this page