Thread Rating:
  • 8 Vote(s) - 2.13 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Have an 04, 2.0 hdi with 45000 on the clock. Recently it's been a bit sluggish so I replaced the fuel filter housing. Took it for a test drive it was fine. Next time it was started up, it was back to it's old sluggish self. Sat in neutral i can't get it to rev past 2750 rpm. No warning lights are lit. Any ideas or can anyone recommend a good garage in the Sunderland area. Thought I'd found one but he turned out to be a tosser. TIA
"Sat in neutral i can't get it to rev past 2750 rpm." - What about driving? Can you get over 55mph? If not, sounds like you have gone into limp/safe mode. There are many reasons why this might be. You will need to get the fault codes read and these will indicate where the problem lie. Trying to diagnose problems without these codes is difficult, at best, and could lead to unnecessary expense. Every garage should have a code reader and be able to tell you what's wrong
i had the same thing,no engine light warning but it was in limp was the egr solenoid,the valve under the airfilter box with 2 black air pipes coming from goes to egr valve other goes to vacuum pump.but without code reader as already said in previous post its guesswork
Thanks to you both. Have previously had a warning light which was apparently egr valve related. Had removed valve for cleaning but it didn't seem too bad.
Is there any way to test the solenoid myself? TIA
Disconnected the battery for 30 mins and then went for a spin. No problems, running like a dream. Let's hope it stays that way.
hope it stays that way, mine was intermitant,so i took it to pieces,there is not a lot you can do but after removing the bottom you will see an allen key screw i turned it fully anti-clockwise and put it problem since and the car is a flyer now.the solenoid that is not egr valve sorry!

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Speedo light not working?
Last Post:brodfather11
Today 04:11 PM
» Replies: 1
» Views: 19
Front camber out of align...
Last Post:Civvic
Today 02:57 PM
» Replies: 9
» Views: 164
Lexia Scanner?
Last Post:cancunia
Today 02:30 PM
» Replies: 0
» Views: 19
Eco activated but engine ...
Last Post:doofer
Today 02:28 PM
» Replies: 20
» Views: 455
1.9 dw8 to b 1.8 xud engi...
Last Post:Angusyoung1
Today 01:46 PM
» Replies: 0
» Views: 18
Brand new alloys and tyre...
Last Post:Wadling09
Today 11:13 AM
» Replies: 0
» Views: 44
My Berlingo Camper build....
Last Post:Madhouse
Today 09:14 AM
» Replies: 4
» Views: 255
M49 Budget DIY Camper con...
Last Post:knownowt
Today 08:49 AM
» Replies: 22
» Views: 2346
Last Post:Jane Rushby
Yesterday 08:43 PM
» Replies: 3
» Views: 67
Roof bars for VTR?
Last Post:Jed Clampit
Yesterday 07:57 PM
» Replies: 1
» Views: 44

Locations of visitors to this page