Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Leaking fuel and New rear shocks
#1
Hi guys.

My 2001 1.9D Berlingo passed it's MOT last month with a couple of advisories (couple of tyres, and the driver's side rear shock absorber). The van was struggling to start and I was advised to change the glow plugs, which I did myself, and no more starting issues.

Since changing the glow plugs I've been smelling fuel when I finish driving and leave the vehicle, or if I have the heaters on. I checked today and there's a cable exposed that when the engine is running drips fuel. I've took the engine apart the same way I did the glow plugs and can't find where this cable has come from so I can reconnect it. I didn't intentionally pull it out so it must've happened while changing plugs.

Also I had the garage change the two rear shock absorbers. Since being changed when I hit a bump in the road there's a banging from the shocks and the van seems very bouncy like a water bed. The garage said this is correct for 200-300 miles as there's no springs with this model. Does anyone know if this is correct?

Thanks for your time reading my post and any responses would be much appreciated

Sent from my SM-G361F using Tapatalk
Reply
#2
[Image: 2b91d0c085b23e7768f88af343b2b856.jpg][Image: af78e19cd6de7b22599ceadcabc351fb.jpg]7516e8a2.jpg[/IMG]


Some pics of the cable dripping fuel

Sent from my SM-G361F using Tapatalk
Reply
#3
[Image: e29ce00f1dcce71121c54dfe278da0a9.jpg]

Sent from my SM-G361F using Tapatalk
Reply
#4
Sorry I can't identify the part but it looks like a pipe has broken off some plastic connector. You need to have a good look for anything you have disturbed doing the glow plugs.
Griff
Landmark
Ex 1.4 Berlingo Multispace
Reply
#5
Similar thing happened to myb m49 1.4 but it was the plastic brake booster nipple over the back of the intake manifold.
All I did was dremel it out and tap it to accept a new 1/4" brass barb    
Reply
#6
Damper issue doesn't sound normal to me, I've fitted a few over the years to a variety of vehicles and never had that problem. The method of fitting used to be fully extending and compressing the dampers several times before attaching them to the vehicle.
That was with oil filled units which I believe your vehicle has ?
Reply
#7
Update:

Sorted fuel leak. The broken pipe had snapped off from the lid of the fuel filter housing. A trip to a local scrap yard I sourced the lid and replaced, no more fuel problems.

Sent from my SM-G361F using Tapatalk
Reply
#8
Glad you've sorted that one
Landmark
Ex 1.4 Berlingo Multispace
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Bottom Ball joint
Last Post:Andyy
Today 08:06 PM
» Replies: 4
» Views: 44
peugeot charger
Last Post:geoff
Today 06:35 PM
» Replies: 4
» Views: 113
cutting out HDi 1.6 diese...
Last Post:Col
Today 06:15 PM
» Replies: 18
» Views: 1425
Poor cold startup 1.9
Last Post:Top drive
Today 06:10 PM
» Replies: 34
» Views: 789
hello
Last Post:ron
Today 05:22 PM
» Replies: 1
» Views: 32
Lower Ball Joint
Last Post:brodfather11
Today 03:36 PM
» Replies: 1
» Views: 47
starting problem
Last Post:brodfather11
Today 03:32 PM
» Replies: 1
» Views: 37
Washers not working
Last Post:Redjoe100
Today 03:25 PM
» Replies: 6
» Views: 140
citroen berlingo alarm
Last Post:sks01773
Today 11:28 AM
» Replies: 0
» Views: 33
Reverse light switch prob...
Last Post:ffrenchie
Today 09:48 AM
» Replies: 6
» Views: 107

Locations of visitors to this page