Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Warning Light] ABS and cooling fluid illuminated for no reason

I have a problem with my 2007 model Berlingo (1,6 HDI).

When i turn on my  high beam, the ABS and cooling fluid lamp is illuminated. 
The car does not have ABS, and the cooling fluid is filled. 

I tried resetting ECU with an ODB2 diagnostic tool without any results. 

Anyone have any idea what wrong and how to fix it? 

thanks for answers. 

Hi Carsten, i have a similar problem in the winter only when its very damp. Same as you i have no ABS but it illuminates not totally just dim. I also get other dash lights coming on dim but again only when its cold and damp, i put it down to damp getting into something maybe BSI?
Earth problem, try to find your earth points and clean them. I had the same on my bike, cured and I keep them clean and rust free.

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Bump and Run - Am I right...
Last Post:jj9
Today 09:44 AM
» Replies: 13
» Views: 198
Dead BSI unit?
Last Post:ghost123uk
Today 09:03 AM
» Replies: 5
» Views: 129
Injectors and B9 series.....
Last Post:Opensauce
Today 06:55 AM
» Replies: 1
» Views: 53
2004 2.0HDi Cruise Contro...
Last Post:brajomobil
Today 06:29 AM
» Replies: 1
» Views: 57
Radio not working and ele...
Last Post:pscotty
Today 04:02 AM
» Replies: 0
» Views: 27
splayed rear wheels
Last Post:jj9
Yesterday 10:36 PM
» Replies: 7
» Views: 110
Dandav1985's Mk3 Berlingo
Last Post:Jed Clampit
Yesterday 10:16 PM
» Replies: 8
» Views: 252
Still on the elusive 4x10...
Last Post:doofer
Yesterday 08:47 PM
» Replies: 3
» Views: 141
Car smell...
Last Post:doofer
Yesterday 08:03 PM
» Replies: 1
» Views: 94
srceen wash pump.
Last Post:landcrab
Yesterday 07:18 PM
» Replies: 7
» Views: 206

Locations of visitors to this page