Thread Rating:
  • 1 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
windscreen wiper blade problem
fitted new wiper blades six weeks ago noticed on friday first 3 inches had come away fitted new one diff brand and same thing has happend only happens on near side wiper
Is it too long and hitting widscreen post, or badly adjusted arm hitting bottom of screen?
Silly question ..... the end of the blade isn't making contact with the edge of the screen rubber is it ???

esit : must learn to type faster col beat me to it
(26-04-2016, 12:41 PM)geoff Wrote:  Silly question ..... the end of the blade isn't making contact with the edge of the screen rubber is it ???

esit : must learn to type faster  col beat me to it

no there not touching on the first occasion i thought as whe have had some frosty morning lately i thought it had stuck to the windscreen but not the second one
Check the screen area swept by that part of the blade.There might be some sort of crap cutting the blade.
Strawberry flavoured windows  Dodgy
I always use wipers from places where stock gets used quickly. The rubber used these days on cheaper blades is basically crap and splits in no time, especially if it's been on the shelf for a while
I've used blades from Lidls for several years & find the performance & lifespan very good.
Strawberry flavoured windows  Dodgy
hopefully solved the problem changed the arm got one from scrappy for a fiver the old one was too close to the screen either been bent or off another car time will tell thanks for your repliies
problem solved after another wiper blade ruined we have a rogue crow in the street thats been pulling them clean off on certain cars we are now putting plastic bags over them at night to detur
All that, and its a least you got to the bottom of it,,

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
cooling fans
Last Post:blueiceplus
Today 06:56 AM
» Replies: 2
» Views: 62
My Berlingo Camper build....
Last Post:Sootyfoot
Today 05:11 AM
» Replies: 6
» Views: 294
Roof bars for VTR?
Last Post:Jed Clampit
Yesterday 09:40 PM
» Replies: 4
» Views: 89
2005 Berlingo - Aussie Ow...
Last Post:martybelfasthdi
Yesterday 07:50 PM
» Replies: 14
» Views: 266
Eco activated but engine ...
Last Post:doofer
Yesterday 07:50 PM
» Replies: 22
» Views: 514
Front camber out of align...
Last Post:Col
Yesterday 06:46 PM
» Replies: 11
» Views: 241
P1351 fault code.
Last Post:Boxer
Yesterday 06:28 PM
» Replies: 13
» Views: 778
Upgrading DAB radio recep...
Last Post:Tree
Yesterday 06:26 PM
» Replies: 14
» Views: 2528
Overheating & part number...
Last Post:kevin58
Yesterday 05:55 PM
» Replies: 36
» Views: 17327
Last Post:ron
Yesterday 04:20 PM
» Replies: 4
» Views: 90

Locations of visitors to this page