Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
cutting out HDi 1.6 diesel
#1
hello
i have a Belingo guess its a second edition as it was the first one registered in the uk as an 08 reg.
its now don't 81211 miles, but has started to stall.
its ok on a  short drive between 10 and 30 miles but on a  longer drive of over 125 miles it starts to stutter,  it feels like its misfiring but as its a diesel this isn't possible 
then when pulling to a stop the engine just stops, when trying to pull away.
initially it won't re start but after the 8th attempt it restarted.
it has now done this on 3 different journeys, twice on one journey of 175 miles and once at 150 miles and once at 125 miles.
it has been in for diagnostic tests two times but no faults are reported and  no error lights or warning sounds occur when it brakes down, and no smoke is released.
we have no idea what could be causing it.
the citroen garage say they don't think its the EGR valve even though lots people have suggested this to me, or could it be a fuel injection fault ?
does anyone else ever had this problem.
many thanks
Reply
#2
have you changed the fuel filter?
[Image: 2dedca76-4da1-4bd2-aea1-452ddda68256.jpg]
Reply
#3
(29-04-2016, 06:38 PM)finny Wrote:  have you changed the fuel filter?

hi.
thank you for your reply
its due a service in just under 3000 miles so i am assuming it will be done at that time.
it goes to a citroen garage alway for its services etc.
its been serviced every year, so assuming they are doing the correct filter changes.
my thoughts are its fuel related.
i might add that i have always only used supermarket fuel or esso, but the first time it broke down i had filled the car with Harvest diesel. i don't know if this is just a coincidence.
the last time i filled it up as suggested by the garage i fill it with supreme fuel and i also added an additional additive that the garage gave me, hoping it would stop the problem, but it appears that didn't work.
Reply
#4
Don't assume.Check your bills to make sure.If it's been missed,which is quite possible,changing it might solve your problem.
Strawberry flavoured windows  Dodgy
Reply
#5
Diesel engines can misfire !  
    
injector faults ,leaking fuel pipes , valves, dirty filters and many other things  can cause a misfire in a diesel engine
[+] 1 user says Thank You to brodfather11 for this post
Reply
#6
(30-04-2016, 05:55 AM)brodfather11 Wrote:  Diesel engines can misfire !  
    
injector faults ,leaking fuel pipes , valves, dirty filters and many other things  can cause a misfire in a diesel engine

hi
oh ok i didn't know that.
we are getting very frustrated as never know if or when its going to just stop.
now again waiting to see what the garage think it could be,  but they very reluctant to actually LOOK and check things rather than just rely on what the diagnostics say.
thank for your suggestions
Reply
#7
Thought I would try and be useful being a newbie, I had a Focus with the same engine, sometimes it would run fine but when it got warm it would start to misfire and kangaroo, just like it was running out of fuel. Had it on the diagnostics and the first couple of times it didn't show a fault, then it came up with a crank sensor fault, replaced that and all was well.

I dont even think the sensor was faulty, the wiring to it was very tight and I think it was a bad connection but for a £15 part its worth a try for a quick fix.

BTW the crank sensor was just behind the front aux belt pulley, not the gearbox end, I presume the berlingo is in the same place.
Reply
#8
(02-05-2016, 01:44 PM)Peter Palmer Wrote:  Thought I would try and be useful being a newbie, I had a Focus with the same engine, sometimes it would run fine but when it got warm it would start to misfire and kangaroo, just like it was running out of fuel. Had it on the diagnostics and the first couple of times it didn't show a fault, then it came up with a crank sensor fault, replaced that and all was well.

I dont even think the sensor was faulty, the wiring to it was very tight and I think it was a bad connection but for a £15 part its worth a try for a quick fix.

BTW the crank sensor was just behind the front aux belt pulley, not the gearbox end, I presume the berlingo is in the same place.

Thanks for that all info is useful, lots of suggestions for me to throw at the 'Professionals" .

Its seems to me that the mechanics now days rely on what the diagnostics say rather than them think Mechanical problems.
Thanks again everyone.
Reply
#9
(02-05-2016, 02:24 PM)Belleisa Wrote:  
(02-05-2016, 01:44 PM)Peter Palmer Wrote:  Thought I would try and be useful being a newbie, I had a Focus with the same engine, sometimes it would run fine but when it got warm it would start to misfire and kangaroo, just like it was running out of fuel. Had it on the diagnostics and the first couple of times it didn't show a fault, then it came up with a crank sensor fault, replaced that and all was well.

I dont even think the sensor was faulty, the wiring to it was very tight and I think it was a bad connection but for a £15 part its worth a try for a quick fix.

BTW the crank sensor was just behind the front aux belt pulley, not the gearbox end, I presume the berlingo is in the same place.

Thanks for that all info is useful, lots of suggestions for me to throw at the 'Professionals" .

Its seems to me that the mechanics now days rely on what the diagnostics say rather than them think Mechanical problems.
Thanks again everyone.
Reply
#10
After another longish drive the car cut out again, this time after 125 miles.
i took it in again this morning to be diagnosed and at last a fault code has shown up.
it suggested the Cam shaft sensor was not working properly so they replaced it for me so with luck the car should now not cut out.
and also stop miss firing.
thank you to everyone who made suggestions as to this problem
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
DW8 engine tapping
Last Post:jj9
Today 01:14 AM
» Replies: 3
» Views: 98
Rear window heater repair
Last Post:Silverberlingo
Yesterday 11:38 PM
» Replies: 0
» Views: 38
New PureTech 110 S&S Flai...
Last Post:Jed Clampit
Yesterday 09:04 PM
» Replies: 3
» Views: 64
What website to pass time...
Last Post:Solent
Yesterday 08:32 PM
» Replies: 0
» Views: 42
Berlingo Parts
Last Post:Sb12
Yesterday 07:56 PM
» Replies: 0
» Views: 42
Rear hub nut torque setti...
Last Post:jj9
Yesterday 07:55 PM
» Replies: 15
» Views: 280
temperatue dial
Last Post:Kokain
Yesterday 05:28 PM
» Replies: 3
» Views: 93
Trip Computer on Type A M...
Last Post:cancunia
Yesterday 03:50 PM
» Replies: 0
» Views: 36
Loud beeping from radio u...
Last Post:nicko
Yesterday 03:49 PM
» Replies: 3
» Views: 126
Ligts won't go off!
Last Post:Berlingos12
Yesterday 02:50 PM
» Replies: 10
» Views: 475

Locations of visitors to this page