Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Need some help ASAP
#1
Hello everyone I am new to this site so please bare with me. 

I have a 1999 1.9 dev and it has a few faults. I am pretty hand with cars ect but these have amazed me . The first of is the electrics the heater blower dosnt work at all only very slight and the 12v dosnt work either. Went through the interior fuse box and fount around 7 fuses not live replaced them and still nothing. For some reason there's no power going to some fuses. Any help with these please?  

Many thanks 
Simon
Reply
#2
Do the wipers, lights and horn work and is the heater blower receiving power to work "very slight" ? By "the 12v" do you mean the accessory socket ? Does your car have fuses under the bonnet as well as the ones next to the steering column under the plastic cover ?
So where does this bit go then ?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
2.0 HDi fuel issues as pe...
Last Post:brodfather11
Today 02:05 PM
» Replies: 13
» Views: 217
Haynes manuals - which on...
Last Post:ffrenchie
Today 01:54 PM
» Replies: 4
» Views: 44
Amateur radio
Last Post:ghost123uk
Today 01:41 PM
» Replies: 24
» Views: 8208
peugeot charger
Last Post:grig
Today 01:05 PM
» Replies: 0
» Views: 12
Poor cold startup 1.9
Last Post:Top drive
Today 12:52 PM
» Replies: 17
» Views: 519
Roof noise
Last Post:Shawks
Today 12:03 PM
» Replies: 6
» Views: 165
Heyup
Last Post:ffrenchie
Today 11:08 AM
» Replies: 6
» Views: 281
Fuel flap
Last Post:3rensho
Today 10:01 AM
» Replies: 1
» Views: 42
Poor cold starting. Whats...
Last Post:geoff
Today 09:18 AM
» Replies: 10
» Views: 179
lubricating door
Last Post:ghost123uk
Today 09:13 AM
» Replies: 7
» Views: 166

Locations of visitors to this page