Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Engine resurrection issues
#1
Hi Folks,

I've just replaced the engine in my 2001/2002  Berlingo 2.0hdi dw10. 
Its not starting! 
I'm not too good at diagnosing issues unfortunately.


The engine is turning over.
The glowplug light isnt coming on.
The fuel pump on both engines is the same.
Does my ecu speak to the new injectors/rail?
do i need to re-initialise the ecu.
does the new fuel pump work
have i connected the loom correctly.  
Ive checked the earths.

Any tips would be gratefully received.

Thanks Smile
Reply
#2
Is the equipment the same on new engine (ie injectors)
[+] 1 user says Thank You to Col for this post
Reply
#3
You have to change BSI from donor car to yours also.

You probably have immobilizator issue.

It would be a lot easier if you have some diagnostic equipment.

Best regards,
brajomobil
[+] 1 user says Thank You to brajomobil for this post
Reply
#4
Hi Thanks for the info,

I dont have the donor bsi! I have ordered diagnostic equipment!

I'll let you know how i get on,

Thanks,
Reply
#5
(05-05-2016, 09:52 AM)tortoise365 Wrote:  Hi Thanks for the info,

I dont have the donor bsi!  I have ordered diagnostic equipment!

I'll let you know how i get on,

Thanks,

Then you can do IMMO off on that engine ECU or install original BSI to
match original ECU. Without that engine will not start.

Best regards,
brajomobil
[+] 1 user says Thank You to brajomobil for this post
Reply
#6
(04-05-2016, 12:56 PM)Col Wrote:  Is the equipment the same on new engine (ie injectors)

Good Point! 
 the Old engine has siemens injectors, rail and pump,

The new engine has siemens injectors, bosch rail and the pump has no sticker but looks the same as the old one.

I just want to avoid having to take the injection system apart. cos the haynes says you've got to buy new pipes if you do this. and keep everything clean! 

Thanks again!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Rear hub nut torque setti...
Last Post:El Berlingo
Today 11:58 AM
» Replies: 11
» Views: 164
temperatue dial
Last Post:polar
Today 11:47 AM
» Replies: 1
» Views: 17
Loud beeping from radio u...
Last Post:Tree
Today 08:35 AM
» Replies: 2
» Views: 63
DW8 engine tapping
Last Post:brodfather11
Today 08:30 AM
» Replies: 1
» Views: 44
Washers not working
Last Post:Luis Rosa
Today 07:47 AM
» Replies: 8
» Views: 212
increase in a ratchet-typ...
Last Post:saskak
Today 12:36 AM
» Replies: 7
» Views: 140
Rear Wiper Motor
Last Post:madwelshman
Yesterday 10:42 PM
» Replies: 3
» Views: 121
Heater control unit/resis...
Last Post:mreid63
Yesterday 10:34 PM
» Replies: 5
» Views: 344
Facial light replacement
Last Post:Mike
Yesterday 09:23 PM
» Replies: 11
» Views: 305
Reverse light switch prob...
Last Post:willpisme
Yesterday 08:09 PM
» Replies: 7
» Views: 172

Locations of visitors to this page