Thread Rating:
  • 16 Vote(s) - 2.63 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Back in limp mode
Engine management light back on and car in limp mode. This is starting to become a PITB. A previous visit to a garage flagged the EGR valve. I've had the valve off and it was a bit sooted up but didn't seem too bad, spring operation seemed in good nick. Looked at solenoid valve. Didn't appear as though any form of maintenance could be carried out on that particular part. Hoses appear in good condition.
I can't go on like this. Do I just purchase one or both parts and hope the problem goes away, or are there any tests I can carry out that would identify the faulty part?
Have used the search facility and read through the posts but can't find the necessary info. TIA.
If a previous garage has flagged up the EGR, why not start with that?
Somedays you're the pigeon, Somedays you're the statue.
Do you know what the actual fault code(s) was??

Many of the codes can relate to one of 2 or 3 causes.

My wife's Corsa deisel was giving a fault code that 'suggested' the EGR might be the fault. In actual fact it wasn't and there was a further background code that my reader didn't identify. That code lead me to the glow plugs or the wiring and it turned out two of them were burnt badly. That background code was triggering the turbo to kick out as some sort of safety thing, even though the plugs it would seem, have no bearing on the turbo itself.
i connected the egr pipe directly to the vacuum pump by-passsing the solenoid, you can tell when the egr valve is go for the solenoid replacement if you dont want to fool with the solenoid valve like i did.....inside the top there is a diaphram,i lifted it while the engine was running and it revved all the the bottom is the allen screw i told you about previously turned it anti clock and no more probs...seems to have been sticking inside .turning screw perhaps gives it a new fresh seat inside.
or just get the codes read but remember if there is more than one code showing they will clear them all then tell you to come back when it happens again to see which code is then showing.AND CHARGE FOR TWO VISITS !
good luck with it!
Thanks again for the replies.
lorraine. I've had the solenoid out and couldn't see a way to strip it down without potentially causing damage. Is yours a 2.0hdi? Any tips? TIA
hi solo.yes mines a 2.0 hdi you say it could cause damage,the trick is to carefully prize the plastic clips without snapping them off,i lost one in the process but managed to put it back on.on the bottom the black plastic looks as though it only stops dirt ingress.the top one has a spring inside so must go back on...dont lose it if you decide to open it up watch for it springing out.i dont think it would hurt if the bottom was left off to be honest.try removing bottom first turn screw and replace.if it works then leave top alone as there is nothing in there but a spring and diaphram...good luck again
[+] 1 user says Thank You to lorraine for this post
Thanks for the info.
I'm still going down this bumpy road. My 2004 2.0 HDi came back from a clutch change with a similar problem. The error was a "EGR flow rate" problem. I replaced the electrovalve as it was broken and glued. No difference. Eventually I replaced the EGR valve even though with direct application of the vaccum tube it sounded to open and close. No difference. So be careful how much money you throw at this problem.

As the EGR or pipe to the inlet manifold doesn't have any sensors, I'm left with the conclusion that the EGR flow rate is somehow calculated by using the airflow sensor just behind the air filter. Is this the possible cause?

Berlingo Multispace 2.0 Hdi (04) - 238K@43mpg - 205/60HR15 XL tyres all round
Berlingo Multispace 1.6 16v (51) - 184K@36mpg - SORN & still 15° retarded...
Xantia 1.9TD Temp2 Estate (97) - 208K@42mpg - SORN & no turbo boost...
yeah i also changed the airflow meter £110 genuine part.e-bay £50-80ish it made a hell of a difference.but at that time i had no engine warning light on, and it just ran crap but not limp mode goes ok now the best its ever been in fact.....good luck with it

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Wanted Berlingo / Partner...
Last Post:b-f-c
Today 08:32 AM
» Replies: 0
» Views: 17
Eco activated but engine ...
Last Post:brajomobil
Today 08:10 AM
» Replies: 13
» Views: 301
WTB Rear Hatch in Silver,...
Last Post:Def-fid
Today 07:56 AM
» Replies: 0
» Views: 14
font fog light bulb chang...
Last Post:Luis Rosa
Today 05:31 AM
» Replies: 2
» Views: 47
Putting spare back into c...
Last Post:Col
Yesterday 10:59 PM
» Replies: 7
» Views: 131
B9 Steering wheel
Last Post:Dandav1985
Yesterday 08:48 PM
» Replies: 1
» Views: 57
TDI Tuning, Tuning box fo...
Last Post:Dandav1985
Yesterday 08:46 PM
» Replies: 3
» Views: 176
Berlingo 2.0 hdi multispa...
Last Post:stewc
Yesterday 10:51 AM
» Replies: 0
» Views: 51
Berlingo VTR to ''XTR'' l...
Last Post:doofer
Yesterday 10:11 AM
» Replies: 1
» Views: 124
better late than never, N...
Last Post:doofer
Yesterday 09:56 AM
» Replies: 3
» Views: 169

Locations of visitors to this page