Thread Rating:
  • 8 Vote(s) - 2.88 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Heater "valve" problem
My friend has a 2002 2L HDI Mulitspace (Canbus wiring).

After a two week break, he started the car and drove a few miles and then got a nasty hot electrical smell.

Looking under the bonnet, the alternator was red hot and smoking heavily. The alternator was indeed dead (stator windings cooked) and was replaced with a pukka Valeo 150 amp unit.

The 8 year old battery, though able to start the car reliably, was also replaced with a new one.

But the hot alternator problem remained so he checked around with a meter and found that the new alt was continuously pumping out 80A even once the car was warm with no other loads on.

Looking around he spotted a unit in the heater matrix hose fed by massive cables and found that it was live all the time, drawing a constant load of about 70amps. (RH end of the engine – looking at it – under the intake ducting, below and behind the battery tray). There is no mention of this unit in the Haynes manual or in the wiring diagram.

He’s now disconnected it, the heavy alternator load has gone (6amps now after a few minutes at tickover) and the car seems to be fine. The heater still works as it did originally.

He’s bought a second-hand one off Ebay – called a heater valve – pictured here (from a 2.0HDi Xantia).


Its clearly not a “valve” but appears to be a cluster of glowplugs. We can only assume this a “quick de-frost” device and that the control circuit or relay for this has gone U/S. Presumably it should switch off once the coolant is warm. The vehicle is still running perfectly with this part disconnected.

We hope this helps some else.
'98 D 800 van Big Grin

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Eco activated but engine ...
Last Post:doofer
Today 04:03 PM
» Replies: 16
» Views: 358
Still on the elusive 4x10...
Last Post:doofer
Today 03:03 PM
» Replies: 1
» Views: 57
Berlingo VTR to ''XTR'' l...
Last Post:doofer
Today 12:58 PM
» Replies: 4
» Views: 185
cooling fans
Last Post:blueiceplus
Today 12:57 PM
» Replies: 0
» Views: 17
OBD Eror Code P1351
Last Post:PeteK
Today 11:11 AM
» Replies: 5
» Views: 142
font fog light bulb chang...
Last Post:rdfb2
Today 10:27 AM
» Replies: 3
» Views: 86
Last Post:my mucker
Today 10:17 AM
» Replies: 2
» Views: 99
Cruise control possible o...
Last Post:cancunia
Today 09:43 AM
» Replies: 1
» Views: 53
Front camber out of align...
Last Post:Civvic
Today 09:21 AM
» Replies: 4
» Views: 72
How the heck do I remove ...
Last Post:CourierJim
Yesterday 11:20 PM
» Replies: 6
» Views: 569

Locations of visitors to this page