Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Factory-fitted stereo
Hi all

After leaving the lights on for a few hours, the battery on the car went dead.  On getting it sorted, the stereo was asking for the radio code.  Having entered the code, the radio comes on but beeps every five seconds before switching off and asking for the code a few minutes later.  Other than replacing, does anyone have any suggestions?

Many thanks
Which model/year is your car? as far as I know up to 08 radios are not coded but auto linked to the car at the factory. Did you follow the reset proceedure for the BCI?
BSI not BCI Big Grin
What year van do you have is it an early mk1? As divingdad says do a BSI reset you have confused the electrics. The radio is coded to the BSI so if it worked before the battery went flat it should work when powered up.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
Thanks all. It's a 1998 model, so it is an early one. How do I do a BSI reset as I don't have remote central locking and all tips I find mention using that? Many thanks.
you don't have a BSI , that only came in the 2001/2 models.

You may be putting in the wrong code or its the way you're putting it in.
You only get so many goes to enter the right code
Go to the search box bottom right of the page you posted in. Type 'radio code' and search. The third post down shows the hand book instructions.
Sorry if I'm not explaining it too well, but the code is def correct and I'm putting it in correctly. The radio comes back on having entered the code but has the intermittent (three-second intervals) beeping thereafter before switching back off and requiring the code again after a few minutes.

This problem has only started since the battery ran flat, though a few weeks after getting the van I had to enter the code as the radio suddenly stopped working. I had to refer to the handbook instructions then to work out how to put the code in and it was fine for a couple of months until I stupidly left the headlights on during the heavy rain on Tuesday since which time the problem complained of has persisted.

I did try the BSI reset this afternoon, but now realise thanks to Brodfather11 that my van doesn't have the BSI and so that was in vain! Any suggestions on what is occurring?
I see you have the mk1 so no BSI unit just the old type code that you enter each time. I havnt had to enter a code for ages in a motor but are you positive you are entering it correctly and following the instructions to the letter.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
Thanks Tomcat. Yes, as sure as I can be that I'm entering it correctly. The unit is off and requiring the code and then, when I put in the code, it comes back on but has the intermittent beeping mentioned. I enter the code and then press preset button 5 to enter/submit it. I'm a bit stumped to be fair and am on the verge of replacing the radio, but loath to do so unless necessary.

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
splayed rear wheels
Last Post:white van woman
Today 08:32 PM
» Replies: 2
» Views: 54
Dandav1985's Mk3 Berlingo
Last Post:Carl Davis Hulin
Today 08:14 PM
» Replies: 7
» Views: 219
Still on the elusive 4x10...
Last Post:Carl Davis Hulin
Today 08:06 PM
» Replies: 2
» Views: 124
Car smell...
Last Post:doofer
Today 08:03 PM
» Replies: 1
» Views: 55
Bump and Run - Am I right...
Last Post:doofer
Today 07:55 PM
» Replies: 8
» Views: 104
Dead BSI unit?
Last Post:Kez
Today 07:22 PM
» Replies: 4
» Views: 98
srceen wash pump.
Last Post:landcrab
Today 07:18 PM
» Replies: 7
» Views: 187
replacing diesel fuel pip...
Last Post:geoff
Today 05:13 PM
» Replies: 35
» Views: 2007
2004 2.0HDi Cruise Contro...
Last Post:cancunia
Today 04:57 PM
» Replies: 0
» Views: 24
M49 1.9 diesel misfire a...
Last Post:jj9
Today 12:29 PM
» Replies: 3
» Views: 108

Locations of visitors to this page