Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Another clutch thread
#1
My clutch is very heavy for the last few inches on the downward movement and has to be pushed the whole way to the floor to get gears, also the peddle has only to be lifted about a quarter of an inch to engage.
The previous owner has told me that a new clutch and cable were fitted recently,
I could put up with the heavy clutch but I am wondering if there is a way of adjusting the cable so that the peddle has to be lifted higher before the van moves?? Huh
Reply
#2
I think the last owner wasn't truthful with you about a new clutch being fitted,if its new clutch and cable it should be light to press down,
Reply
#3
The cables on the Berlingo are crucial, only the genuine ones work correctly, and they are £100 a go, so people fit cheap ones that give this result.
Obviously it's impossible for me to say one way or another, but certainly a possibility.
Reply
#4
I bought it from a dealer and called the previous owner to ask him about it, so I would like to think that he would have been truthful about the work that was done. Having said that I have no idea what quality of parts that were used..
Would I know if it is the cable if I disconnect it and pull it by hand??
Reply
#5
Think the best bet is take to a garage let them have a look,or back to the dealer,
Reply
#6
My Berlingo has a cable less than a year old and something like 15k miles on it.

It is like an on/off switch and has at least 2" of free play when pressing the pedal.

Getting close to the point of getting rid or spending some money on it and keeping it for a few years
Silver Berlingo Multispace 1.4i Forte

Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Reverse light switch prob...
Last Post:Col
Today 07:22 PM
» Replies: 12
» Views: 243
2004 Berlino Aerial
Last Post:Claydontoby92
Today 07:14 PM
» Replies: 0
» Views: 14
2005 2.0 HDI Siemens pump...
Last Post:Woodyrvf750
Today 07:05 PM
» Replies: 0
» Views: 15
Washers not working
Last Post:Silverberlingo
Today 06:54 PM
» Replies: 10
» Views: 268
Fuse is burning all the t...
Last Post:fernandoblas
Today 05:23 PM
» Replies: 12
» Views: 410
HELP! Smashed passenger w...
Last Post:Sootyfoot
Today 04:31 PM
» Replies: 2
» Views: 68
Diagnostic "gear" / Softw...
Last Post:cancunia
Today 04:19 PM
» Replies: 15
» Views: 612
Poor cold startup 1.9
Last Post:Top drive
Today 02:01 PM
» Replies: 38
» Views: 1031
Berlingo Parts
Last Post:malgpz900
Today 10:20 AM
» Replies: 1
» Views: 86
XTR heater control bulb r...
Last Post:Opensauce
Today 09:19 AM
» Replies: 1
» Views: 80

Locations of visitors to this page