Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Multispace 1.8 petrol strange idling problem
Hi all

Sorry for asking so much and contributing so little!  My Berlingo has developed an odd thing over the past day or so. Basically the idle speed is going up to about 1,400 rpm when in neutral, having just stopped, or is slow to go back down its normal 1,000 rpm idle speed.  Probably not explaining it too well - apologies - but I suppose it's like a sticky accelerator cable, except I'm not sure that it is.  Any ideas?

Many thanks
Hi, Yes make sure the cable if free and it's returning back. Also make sure there are no splits/loose hoses effecting the air flow.
Ex 1.4 Berlingo Multispace
Idle control valve
Thanks both. I'll have a look.
Hi all, back to the drawing board. The accelerator cable is moving freely and is not jamming. There are no leaks or holes in the air hoses. In addition, today the van nearly cut out (but didn't) as the revs went down to about 600 rpm. I'm not mechanically minded, but am going towards the ICV as the culprit. What do you reckon? What else could it be apart from the ICV? Thanks as always. Love this forum!
Like I said sounds like idle control valve,
Cheers Johny. I'll order one and see whether that cures it.
Hello GSLondon also check the mass air flow meter could need a clean or replacing be careful it can easy damage .
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy

Let us know if you fixed it,cheers
Ta both. Have checked the MAF and seems okay. I'm picking up a new idle control valve - £90! - and will see how that gets on.

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
M49 1.9 diesel misfire a...
Last Post:jj9
Today 10:51 AM
» Replies: 5
» Views: 134
replacing diesel fuel pip...
Last Post:Col
Today 10:30 AM
» Replies: 36
» Views: 2045
Bump and Run - Am I right...
Last Post:Opensauce
Today 10:26 AM
» Replies: 14
» Views: 213
Dead BSI unit?
Last Post:ghost123uk
Today 09:03 AM
» Replies: 5
» Views: 133
Injectors and B9 series.....
Last Post:Opensauce
Today 06:55 AM
» Replies: 1
» Views: 56
2004 2.0HDi Cruise Contro...
Last Post:brajomobil
Today 06:29 AM
» Replies: 1
» Views: 59
Radio not working and ele...
Last Post:pscotty
Today 04:02 AM
» Replies: 0
» Views: 27
splayed rear wheels
Last Post:jj9
Yesterday 10:36 PM
» Replies: 7
» Views: 112
Dandav1985's Mk3 Berlingo
Last Post:Jed Clampit
Yesterday 10:16 PM
» Replies: 8
» Views: 253
Still on the elusive 4x10...
Last Post:doofer
Yesterday 08:47 PM
» Replies: 3
» Views: 141

Locations of visitors to this page