Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Rear left indicator light
#1
Hi all my rear left side indicator light blows at least once every two month. Any ideas what the problem could be 
I'm driving berlingon 625 LX HDI 75
Reply
#2
Check the left light cluster wiring connection for poor connections and corroding and the earth. Try running a new earth from inside the light cluster metalwork to a good earth on the body I have seen a few with corroded pins causing problems.
Update sorry didn't realize you had the latest B9 van I was talking about the earlier M59 models.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply
#3
Thanks I will certainly check that out tomorrow
Reply
#4
What make of bulbs are you using, because 90% sold seem to be rubbish, worth considering.
Reply
#5
I've got these in my rear indicators...

http://www.aliexpress.com/item/2Pcs-PY21...00151.html

Quite expensive, and delivery takes weeks, but they're superb and should last for ever. About as bright as a bulb, but more visible, especially as you get the fast on/off you get with LEDs instead of the fading/dimming you get with a bulb - I assume everyone else is half-blind, and don't want to be crashed into. I don't get any messages or fast flashing with them in the rear, but do if I fit them at the front. I'm just about to add a loading resistor so I can fit them in the front too. You also lose the "fried egg" effect, as they're not yellow when off.

I've already replaced the side indicator with an LED too, again with no problems.
Reply
#6
(14-07-2016, 10:09 AM)doofer Wrote:  I've got these in my rear indicators...

http://www.aliexpress.com/item/2Pcs-PY21...00151.html

Quite expensive, and delivery takes weeks, but they're superb and should last for ever.  About as bright as a bulb, but more visible, especially as you get the fast on/off you get with LEDs instead of the fading/dimming you get with a bulb - I assume everyone else is half-blind, and don't want to be crashed into.  I don't get any messages or fast flashing with them in the rear, but do if I fit them at the front.  I'm just about to add a loading resistor so I can fit them in the front too.  You also lose the "fried egg" effect, as they're not yellow when off.

I've already replaced the side indicator with an LED too, again with no problems.

Unusall looking bulbs,and would these be compatible with my van
Reply
#7
(13-07-2016, 10:05 PM)Lighty Wrote:  What make of bulbs are you using, because 90% sold seem to be rubbish, worth considering.

Hi I've just been buying bulbs from halfords
Reply
#8
(15-07-2016, 06:21 PM)Jamesaitchy Wrote:  
(13-07-2016, 10:05 PM)Lighty Wrote:  What make of bulbs are you using, because 90% sold seem to be rubbish, worth considering.

Hi I've just been buying bulbs from halfords

Not or wanting to criticise them, but best to get a brand that is well known like Osram or Philips. 
Suspect Halfords would use a bulb for max profit, and not quality.
we use to buy cheap bulbs, as they cost pence to buy and you make a few quid extra, but it gets embarrassing when customers keep coming back with the same fault. 
We now only use Osram , which are not exactly ridiculously priced , and we get zero come backs.
Reply
#9
(15-07-2016, 06:18 PM)Jamesaitchy Wrote:  
(14-07-2016, 10:09 AM)doofer Wrote:  I've got these in my rear indicators...

http://www.aliexpress.com/item/2Pcs-PY21...00151.html

Quite expensive, and delivery takes weeks, but they're superb and should last for ever.  About as bright as a bulb, but more visible, especially as you get the fast on/off you get with LEDs instead of the fading/dimming you get with a bulb - I assume everyone else is half-blind, and don't want to be crashed into.  I don't get any messages or fast flashing with them in the rear, but do if I fit them at the front.  I'm just about to add a loading resistor so I can fit them in the front too.  You also lose the "fried egg" effect, as they're not yellow when off.

I've already replaced the side indicator with an LED too, again with no problems.

Unusall looking bulbs,and would these be compatible with my van

I don't know what your van is, but they're great in my Berlingo Multispace. None available at the moment, but I assume similar are available elsewhere.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Rear hub nut torque setti...
Last Post:El Berlingo
Today 01:14 PM
» Replies: 3
» Views: 43
Poor cold startup 1.9
Last Post:jj9
Today 09:42 AM
» Replies: 35
» Views: 844
peugeot charger
Last Post:Jed Clampit
Yesterday 11:28 PM
» Replies: 5
» Views: 164
hello
Last Post:Jed Clampit
Yesterday 11:16 PM
» Replies: 2
» Views: 56
XTR heater control bulb r...
Last Post:VicG
Yesterday 10:57 PM
» Replies: 0
» Views: 40
Fuel consumption
Last Post:ron
Yesterday 09:41 PM
» Replies: 12
» Views: 307
Rear Wiper Motor
Last Post:minisandfords
Yesterday 08:48 PM
» Replies: 2
» Views: 96
Lower Ball Joint
Last Post:brodfather11
Yesterday 08:38 PM
» Replies: 2
» Views: 102
Bottom Ball joint
Last Post:Andyy
Yesterday 08:26 PM
» Replies: 6
» Views: 117
cutting out HDi 1.6 diese...
Last Post:Col
Yesterday 06:15 PM
» Replies: 18
» Views: 1479

Locations of visitors to this page