Thread Rating:
  • 7 Vote(s) - 3.29 Average
  • 1
  • 2
  • 3
  • 4
  • 5
engine light
#1
Exclamation 
The yellow engine light is staying on. It's a 1.6hdi, nothing seems out of the ordinary. Economy might be slightly down. Any ideas? What does this light cover?
Reply
#2
Didn't go out to check mine but might it be that a service is due soon?
2010 Berlingo Multispace HDi 110 with FAP. Persamos green.

[Image: ab197646.gif]
Reply
#3
Nope 10k left to service and that's for 15k intervals not 20k
Reply
#4
Needs a diagnostic or coupling to a code reader to give you a clue otherwise you might as well urinate in the prevailing wind...
Berlingo Multispace 2.0HDI '54 reg Mediterranean Blue
[+] 1 user says Thank You to andy-womble for this post
Reply
#5
Went away for 2 days then came back this morning. Went to limp mode until I reset.
Reply
#6
Got it read. It's low fuel rail pressure.

So first thing replace the fuel filter.

Reply
#7
changed the fuel filter, dead easy starts straight away.
hope that solves it
Reply
#8
(31-10-2011, 04:16 PM)corkgsxr Wrote:  changed the fuel filter, dead easy starts straight away.
hope that solves it

When did you last change it? Fuel filters should be changed every major service iirc.
Want Help with the Forum? Read Help Documents Here
 [Image: mybbsig.php]

Reply
#9
Never did. Ment to have been done before I bought it and id do it every second service. Iv only one service done so it was to be next one.

Hasn't went to limp mode yet so I do hope that was it
Reply
#10
(31-10-2011, 08:18 PM)corkgsxr Wrote:  Never did. Ment to have been done before I bought it and id do it every second service. Iv only one service done so it was to be next one.

Hasn't went to limp mode yet so I do hope that was it

Fingers crossed for you. Was the fuel filter a simple in out job? Our engine management light has been on for a while now, and its starting to not like starting up/revs drop till stall sometimes. I thought it was the cat at first, obviously not...
Want Help with the Forum? Read Help Documents Here
 [Image: mybbsig.php]

Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Roof noise
Last Post:Shawks
Today 12:03 PM
» Replies: 6
» Views: 154
Poor cold startup 1.9
Last Post:CHRISPY59
Today 11:42 AM
» Replies: 16
» Views: 511
Heyup
Last Post:ffrenchie
Today 11:08 AM
» Replies: 6
» Views: 279
Haynes manuals - which on...
Last Post:b-f-c
Today 10:25 AM
» Replies: 2
» Views: 32
Fuel flap
Last Post:3rensho
Today 10:01 AM
» Replies: 1
» Views: 31
2.0 HDi fuel issues as pe...
Last Post:G.mk3
Today 10:01 AM
» Replies: 9
» Views: 172
Poor cold starting. Whats...
Last Post:geoff
Today 09:18 AM
» Replies: 10
» Views: 170
lubricating door
Last Post:ghost123uk
Today 09:13 AM
» Replies: 7
» Views: 162
2012 enterprise berlingo ...
Last Post:Top drive
Today 06:57 AM
» Replies: 10
» Views: 273
Rear light Cluster
Last Post:Jed Clampit
Yesterday 09:52 PM
» Replies: 6
» Views: 144

Locations of visitors to this page