Thread Rating:
  • 15 Vote(s) - 3.13 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Key fob doesnt unlock central locking
Hi, I have a 1998 Berlingo. I have a niggly problem with my keyfob. Mabye somebody knows how to sort this out.

I got a 2nd hand ignition as the old one was worn with a new key. I replaced the electronics board and the chip inside the new key with the board and chip from the old key. This works fine. The immobilser accepts the new key ( and new ignition).

The problem with the electroncis board is that the button that activates the locking mechanism was worn. I replaced that with a new button that I soldered on. This seems to work as each time I press the onbaord LED light activates.

However, the locking mechanism is not responding.

Does anyone know if this scenario requires reprogramming of the chip or the electronics board and where can you get this done for how much approximately?

I have investigated and some sites talk about reprogramming for the immobiliser. However, the replacement key works fine with my immobiliser but NOT with the central locking.

The user-manual also mentions that in order to re-link the key to the immobiliser after batteries have been replaced it must be placed into the ignition the motor should be started and then the button must be pressed. I did all that but the central locking still doesn't respond.

There are two possible scenarios i can see here:
I might have Physcially damaged the board while soldering ( but I don't know how to chekc for that ) or the integrated chips require some form of resetting after the heat from the soldering iron.

any advice appreciated. It would stop me from messing around with two keys.
I hope that you used a gas soldering iron!
The reason is that the residual ripple current in the tip of a mains iron is enough to damage any chip nearby the component that you've soldered in if you didn't unplug it before you used it on the board.
Hopefully this isn't the case and the BSI just needs re-programming/ resetting. If the vehicle that you got the board from didn't have central locking it may be that it just needs activating via Lexia. HTH :thumbsup:
[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Black Smoke
Last Post:old son
Today 10:59 AM
» Replies: 4
» Views: 112
2012 berlingo radio setti...
Last Post:doofer
Today 10:58 AM
» Replies: 11
» Views: 228
New Battery
Last Post:doofer
Today 10:56 AM
» Replies: 5
» Views: 90
Cruise control possible o...
Last Post:brajomobil
Today 10:09 AM
» Replies: 2
» Views: 99
Berlingo VTR to ''XTR'' l...
Today 09:52 AM
» Replies: 6
» Views: 262
Strange exhaust blowing n...
Last Post:ffrenchie
Today 08:53 AM
» Replies: 2
» Views: 64
P1351 fault code.
Last Post:Boxer
Today 07:27 AM
» Replies: 16
» Views: 848
Lexia Scanner?
Last Post:brajomobil
Today 06:44 AM
» Replies: 1
» Views: 80
Dead BSI unit?
Last Post:brajomobil
Today 06:26 AM
» Replies: 3
» Views: 55
My Berlingo Camper build....
Last Post:Jed Clampit
Yesterday 09:58 PM
» Replies: 8
» Views: 372

Locations of visitors to this page