Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
1.6 hdi issues
#1
Hi, I picked up my second berlingo 1.6 hdi this time a 75 model.
62k on the clock, 07 plate.

After driving it for a couple of days I've noticed that the turbo makes a high pitched whistle like noise, however the turbo is new as it is immaculate and the garage I bought it from said it was new. (Reputable garage)

It also has a really hesitant and juddery acceleration. It only happens in 4th and 5th gear and only ever does it if you put your foot down. You can change in to either 4th or 5th early at low revs and put your foot down and it won't do it.

I've adjusted the brake pedal switch as I read somewhere that apparently this can cause it. But that hasn't worked.

No fault codes are showing up, no warning loghts on the dash etc.

What could it possibly be?

Worst case, injector maybe? But surely this would be constant throughout every gear as I've had injectors go in my trafic van once.

Egr? Could it be possibly stuck open/closed

Throttle position sensor? (If it has one)

Are the throttles fly by wire? Could this be faulty.

It is extremely annoying! Any help and suggestions would be greatly received.

Cheers

Steve
Reply
#2
Take it back to them to fix it
Reply
#3
Just got off the phone to them. It's going in tomorrow morning
Reply
#4
Sounds like they may have either just replaced the turbo or used a second hand one.

If you don't replace all the oil feed pipes you have invalidated any warranty on the turbo

I agree with above poster

Take it back, ASAP
Silver Berlingo Multispace 1.4i Forte

Reply
#5
There is a brand new oil feed pipe on there and they told me they even changed that little gauze type filter thing.

After further inspection one of the injectors is covered in thick black sticky mess all around the seal, that is until it cools then it becomes rock solid. My bet is the injector seal has gone causing a misfire.

It's going back in at 8am tomorrow anyway so I'll let you know what the outcome is
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
1.6 16v petrol cambelt
Last Post:cancunia
Yesterday 11:59 PM
» Replies: 13
» Views: 261
Ncb help
Last Post:Jed Clampit
Yesterday 10:32 PM
» Replies: 5
» Views: 151
Saying Hello
Last Post:Jed Clampit
Yesterday 10:25 PM
» Replies: 1
» Views: 27
1.6 hdi 90bhp Turbo and i...
Last Post:Floydster
Yesterday 07:48 PM
» Replies: 3
» Views: 139
Heated wing mirrors
Last Post:Trevor
Yesterday 07:06 PM
» Replies: 3
» Views: 91
2025 Diesel Ban
Last Post:Tree
Yesterday 06:17 PM
» Replies: 15
» Views: 357
Hello
Last Post:Johny555
Yesterday 06:04 PM
» Replies: 1
» Views: 20
Roof noise
Last Post:Veitcast
Yesterday 05:48 PM
» Replies: 0
» Views: 34
Fuel consumption
Last Post:Opensauce
Yesterday 05:37 PM
» Replies: 3
» Views: 57
Lexia clone that works wi...
Last Post:kennard
Yesterday 02:59 PM
» Replies: 58
» Views: 1843

Locations of visitors to this page