Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Warning Light] STOP & Brake warning light
#1
I have just changed drivers side brake cylinder and bled brakes....the handbrake works real good and the brakes feel firm, the pedal doesn't move when my foot is hard down on it...but the stop warning light is on and the brake warning light too... I checked level of brake fluid n topped up as I bled...

Does anyone e have any ideas????

The van is a 2006. 1.9D. Non turbo Berlingo

Thanks in advance!

Sooty
French Electrics......Grrrrrrr! Dodgy
Reply
#2
There might be nothing wrong, they are known for being very sensitive, I found that hilly or windy twisty roads made mine go off but it stopped after I topped it up... is the light constantly on? mine usually went off a few miles down the road...
[+] 1 user says Thank You to miccheck1516 for this post
Reply
#3
Yes. I drove about ten miles after I read your post. Job done. Thanks for the reply. I thought I had buggered something up!

Sent from my MotoE2(4G-LTE) using Tapatalk
French Electrics......Grrrrrrr! Dodgy
Reply
#4
mine used to drive me nuts,if it came on I had to stop,even though you know there's nothing wrong,i ended dripping fluid in to nearly the top of the filter,mine also came on after a spell on yorkshire dale roads etc,been ok for over a year....touch wood :-)
[Image: smokingdog-1.gif]

Berlingo First,75bhp 1.6hdi,58 plate....225k and counting.
[+] 1 user says Thank You to ians_lingo for this post
Reply
#5
Aye mine is filled well past the max also...

Sent from my HTC One_M8 using Tapatalk
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Running on chip oil
Last Post:cancunia
Today 09:51 AM
» Replies: 4
» Views: 62
2004 Berlino Aerial
Last Post:malgpz900
Today 09:37 AM
» Replies: 3
» Views: 56
2005 2.0 HDI Siemens pump...
Last Post:cancunia
Today 09:05 AM
» Replies: 1
» Views: 54
1.6 hdi 90bhp Turbo and i...
Last Post:peteh80
Today 06:58 AM
» Replies: 4
» Views: 232
Poor cold startup 1.9
Last Post:Top drive
Today 12:24 AM
» Replies: 40
» Views: 1107
Washers not working
Last Post:Lighty
Yesterday 09:09 PM
» Replies: 11
» Views: 321
Reverse light switch prob...
Last Post:Col
Yesterday 07:22 PM
» Replies: 12
» Views: 285
Fuse is burning all the t...
Last Post:fernandoblas
Yesterday 05:23 PM
» Replies: 12
» Views: 423
HELP! Smashed passenger w...
Last Post:Sootyfoot
Yesterday 04:31 PM
» Replies: 2
» Views: 89
Diagnostic "gear" / Softw...
Last Post:cancunia
Yesterday 04:19 PM
» Replies: 15
» Views: 631

Locations of visitors to this page