Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ECO mode ????
Really, really cheesed off, (polite comment for forum), with the irregular operation of the Eco mode on my 16 plate auto Berlingo. 
All worked well for months but now the Eco green dash light flashes but no engine rest when stopped at lights etc. I quickly realised months ago that Eco does not operate with lights on ....why???
All internal switches are off in daylight but Eco still not working, operating switch not disabled as message on screen confirms this, all I get is a flashing Eco green dash light and a running engine.
Am I missing something? no guidance in handbook on this at all.
Help please.
The problem with this will be battery related most likely. Unless the stop start battery is fully charged, then the system won't work, especially if you are using lights etc.
Get the battery professionally tested, if it ok, then put it on a correct charger for 24 hrs.
[+] 1 user says Thank You to Lighty for this post
It sounds like it's absolutely fine and doing as it should. It keeps running either if it's cold and the heater's running or if it's hot and you're using the air con.

If you switch the air con off you should find that it does stop the next time. Mine has auto climate control, so I don't even know whether the air con compressor is on, but I find that it doesn't stop while the cabin's hot, then after it's cooled down it will stop. If it's a really hot day then it never stops - presumably this is when the compressor's running.

Personally, I'd prefer it to ignore whether the air con's on and leave me to get hot as I'd prefer to save diesel, but I think they're just trying to look after us.
[+] 1 user says Thank You to doofer for this post

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Rear reversing sensors
Last Post:Luis Rosa
Today 04:35 AM
» Replies: 1
» Views: 54
Help Surging/loosing powe...
Last Post:michaelg
Today 01:55 AM
» Replies: 5
» Views: 45
Roof bars for VTR?
Last Post:jimss
Today 12:39 AM
» Replies: 7
» Views: 160
Lack of power Then surge ...
Last Post:michaelg
Yesterday 10:34 PM
» Replies: 6
» Views: 212
something new
Last Post:Matt Haigh
Yesterday 10:26 PM
» Replies: 1
» Views: 55
Last Post:ntm1275
Yesterday 09:51 PM
» Replies: 2
» Views: 80
Last Post:ron
Yesterday 07:46 PM
» Replies: 6
» Views: 153
Poor fuel economy.. again...
Last Post:Jane Rushby
Yesterday 06:50 PM
» Replies: 13
» Views: 1423
Where Did you find
Last Post:Jane Rushby
Yesterday 06:26 PM
» Replies: 93
» Views: 165515
Radio needs VIN programme
Last Post:Tomcat3
Yesterday 06:09 PM
» Replies: 3
» Views: 139

Locations of visitors to this page