Thread Rating:
  • 18 Vote(s) - 3.33 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Centre Display
#1
Question 
As a newbie to the Berlingo I have a question about the centre display. Apologies if this has been asked before.

I removed the radio cassette player today and front centre dash (when I worked out how to do it) to check my electric window switches for power as the passenger side doesnt work but the drivers side does.

I removed the multiplugs from the radio and later refitted back in situ. When I came to turn on the Centre Display was very very dim. I am hopefully suspecting that all the bulbs 3 of them may have failed whilst disconnecting is that the case or have I buggered the centre display assembly? I have owned the car for a week now and it was working fine until I disconnected the radio.

Help or advice appreciated

Thanks
Andy
Reply
#2
(09-10-2011, 10:17 AM)Newspaperman Wrote:  As a newbie to the Berlingo I have a question about the centre display. Apologies if this has been asked before.

I removed the radio cassette player today and front centre dash (when I worked out how to do it) to check my electric window switches for power as the passenger side doesnt work but the drivers side does.

I removed the multiplugs from the radio and later refitted back in situ. When I came to turn on the Centre Display was very very dim. I am hopefully suspecting that all the bulbs 3 of them may have failed whilst disconnecting is that the case or have I buggered the centre display assembly? I have owned the car for a week now and it was working fine until I disconnected the radio.

Help or advice appreciated

Thanks
Andy
Before you started unplugging things did you disconnect the battery following the process on this link :
http://www.bba-reman.com/content.aspx?co...ot_process

If you didn`t follow the above process you may have blown a fuse or caused the BSI to throw a wobbly.

Disconnect battery following method on above link then check all fuse`s then reconnect battery following link.

I am going from Yorkshire down to Gravesend today work related when I get back wednesday I will try and sort out some wiring diagrams out for your electric windows this will take out all the guess work for you.

2003 Citroën Berlingo 2.0HDi Multispace Desire
Reply
#3
which fuse? you can see the display all beit very very dimly
Where are the fuses on a Berlingo - No handbook
Reply
#4
(09-10-2011, 10:45 AM)Newspaperman Wrote:  which fuse? you can see the display all beit very very dimly
Where are the fuses on a Berlingo - No handbook

Cover unclips below steering wheel to reveal BSI Rotate two clips 90 degrees & BSI can be pulled out to access fuse`s easier.
There are also fuse`s in the BSM unit under bonnet LHS of battery you will see a cover that unclips to reveal fuse`s.

Search on this forum here http://www.berlingoforum.co.uk/forumdisplay.php?fid=39
& you will find a link to download your handbook.
From this you will find two lists for above fuse`s with correct ratings /purpose of fuse.

2003 Citroën Berlingo 2.0HDi Multispace Desire
Reply
#5
Wasnt the BSI thankfully. Removed the display and removed and tested each R509T twistlock bulb assembly. ALL 3 BULBS HAVE BLOWN.
Went onto fleabay and purchased LED 1.2W R509T equivalents instead of standard bulbs 5.99 for 4 bargain.

Tip- I have been running without the display over the weekend. The Radio will not work with the display removed the radio does not power on going to wait till the bulbs arrive before reassembly.
Reply
#6
(16-10-2011, 10:58 AM)Newspaperman Wrote:  Wasnt the BSI thankfully. Removed the display and removed and tested each R509T twistlock bulb assembly. ALL 3 BULBS HAVE BLOWN.
Went onto fleabay and purchased LED 1.2W R509T equivalents instead of standard bulbs 5.99 for 4 bargain.

Tip- I have been running without the display over the weekend. The Radio will not work with the display removed the radio does not power on going to wait till the bulbs arrive before reassembly.

Thanks for the update. There is a thread in the how to section on changing these bulbs.

Want Help with the Forum? Read Help Documents Here
 [Image: mybbsig.php]

Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
2012 enterprise berlingo ...
Last Post:Top drive
Today 06:57 AM
» Replies: 10
» Views: 251
Poor cold starting. Whats...
Last Post:Top drive
Today 06:24 AM
» Replies: 9
» Views: 124
lubricating door
Last Post:ron
Yesterday 10:21 PM
» Replies: 6
» Views: 147
Rear light Cluster
Last Post:Jed Clampit
Yesterday 09:52 PM
» Replies: 6
» Views: 135
2.0 HDi fuel issues as pe...
Last Post:G.mk3
Yesterday 08:52 PM
» Replies: 6
» Views: 142
1.6 16v petrol cambelt
Last Post:sks01773
Yesterday 07:27 PM
» Replies: 16
» Views: 381
Roof noise
Last Post:Opensauce
Yesterday 06:39 PM
» Replies: 5
» Views: 136
12v for lighter front
Last Post:Matija Danko
Yesterday 05:15 PM
» Replies: 19
» Views: 432
Fuel consumption
Last Post:ron
Yesterday 04:30 PM
» Replies: 7
» Views: 162
Lexia clone that works wi...
Last Post:kennard
Yesterday 04:22 PM
» Replies: 60
» Views: 1926

Locations of visitors to this page