Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
1.6hdi not getting to optimum temperature. And PAS leak.
#1
Hi all,

Since I've owned this beast of a van it has never gotten to the optimum temperature and has always sat at around 60-70, the only time it creeps up is in traffic, but as soon as you drive off the temp drops straight down again. 

I have already replaced the thermostat, any ideas?

Also there seems to be a fairly heavy PAS leak. I can only trace it to the union before it runs into the steering rack. Any ideas?

Many thanks.
Reply
#2
Year, engine and location?

This will assist people in helping you - O and yes welcome to the forum
Reply
#3
My apologies, it had been a long day at work!

The van is a 1.6hdi 2008.

And I joined the forum about 2 years ago, however I couldn't manage to log in. Thanks none the less!
Reply
#4
Best to verify the temp indepedantly. You may have a gauge or sender that's reading wrongly.
Reply
#5
Is it getting hot inside when you put blower on,?,I had a old combo ran really cool,had 3 thermostats in it,never did cure it,in the end I blocked half the rad off with some ply,was like it for the 6 years I owned it,
Reply
#6
(11-10-2016, 11:43 AM)Johny555 Wrote:  Is it getting hot inside when you put blower on,?,I had a old combo ran really cool,had 3 thermostats in it,never did cure it,in the end I blocked half the rad off with some ply,was like it  for the 6 years I owned it,

Johny you are king. That is great DIY.  Smile

Best regards,
brajomobil
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
DW8 engine tapping
Last Post:jj9
Today 01:14 AM
» Replies: 3
» Views: 98
Rear window heater repair
Last Post:Silverberlingo
Yesterday 11:38 PM
» Replies: 0
» Views: 38
New PureTech 110 S&S Flai...
Last Post:Jed Clampit
Yesterday 09:04 PM
» Replies: 3
» Views: 64
What website to pass time...
Last Post:Solent
Yesterday 08:32 PM
» Replies: 0
» Views: 42
Berlingo Parts
Last Post:Sb12
Yesterday 07:56 PM
» Replies: 0
» Views: 42
Rear hub nut torque setti...
Last Post:jj9
Yesterday 07:55 PM
» Replies: 15
» Views: 280
temperatue dial
Last Post:Kokain
Yesterday 05:28 PM
» Replies: 3
» Views: 93
Trip Computer on Type A M...
Last Post:cancunia
Yesterday 03:50 PM
» Replies: 0
» Views: 36
Loud beeping from radio u...
Last Post:nicko
Yesterday 03:49 PM
» Replies: 3
» Views: 126
Ligts won't go off!
Last Post:Berlingos12
Yesterday 02:50 PM
» Replies: 10
» Views: 475

Locations of visitors to this page