Thread Rating:
  • 7 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fuse Box Problems - BSIE
#1
Hi,

I seem to be having what looks lke a common problem. First the dash lights started playing up, and then the wipers, and now the car will not start.

After looking around on the net, it looks like it will be the fault of the fuse box under the steering wheel.

I've taken it out, and got the following numbers off of it;

BSIE01-00HC
S118085320E

Is there any issue with getting a different one, and then just replacing it - are there any programming issues I need to watch out for?

I managed to track a second hand one down, that has the following number:

S118085320A

The difference only being the last number - any idea if this will work?

Finally, if it does not, does anyone know where I could find a second hand unit?

Thanks alot
Chris

Reply
#2
Hi Chris and thanks for saying hello. Might help to know what type of Berli we're talking about here. Then the guru's can chime in.
2010 Berlingo Multispace HDi 110 with FAP. Persamos green.

[Image: ab197646.gif]
Reply
#3
It may be that all that's needed is for the BSI to be reset/or the firmware re-written.
Authorised Citroen repairers can do this and they're cheaper than main dealers.
Although you'll have to find a garage that have Citroen's Lexia
or the Peugeot equivalent it may still prove to be the cheap option.
I very much suspect that if you were to get a s/h BSI unit it would still need to be set up for your vehicle.
HTH:thumbsup:
[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]
Reply
#4
Hi,

Thanks for the reponses so far.
it's a 2007 1,4 petrol van

cheers
chris
Reply
#5
Hi Chris.
Who is manufacturer of BSI? Siemens, Valeo?
Reply
#6
Siemens
Reply
#7
Have you tried the BSI reset procedure? It can be found here:

http://www.bba-reman.com/content.aspx?co...ol_failure

Worth a shot??
Adam..2003..1.9D..LX..Silver Crew Cab Van.....
If at first you don't succeed, destroy all evidence that you tried.
Reply
#8
Does any aftermarket alarm system installed in your car?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
2025 Diesel Ban
Last Post:polar
Today 09:34 AM
» Replies: 4
» Views: 86
1.6 16v petrol cambelt
Last Post:sks01773
Today 09:28 AM
» Replies: 4
» Views: 53
citroen berlingo desire 1...
Last Post:Trevor
Today 09:18 AM
» Replies: 3
» Views: 67
12v for lighter front
Last Post:ghost123uk
Today 09:13 AM
» Replies: 4
» Views: 108
Insurance!
Last Post:ghost123uk
Today 08:48 AM
» Replies: 7
» Views: 852
Berlingo won't start 2009...
Last Post:brodfather11
Today 06:20 AM
» Replies: 8
» Views: 194
B9 DPF Tank Top-Up
Last Post:Lighty
Yesterday 10:06 PM
» Replies: 5
» Views: 117
Rear light Cluster
Last Post:Peter Guy
Yesterday 09:57 PM
» Replies: 2
» Views: 42
2012 enterprise berlingo ...
Last Post:CourierJim
Yesterday 09:03 PM
» Replies: 6
» Views: 130
Head gasket failure.
Last Post:Civvic
Yesterday 08:08 PM
» Replies: 13
» Views: 362

Locations of visitors to this page