Thread Rating:
  • 9 Vote(s) - 2.33 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Head unit turning on when doors opened??
I have recently change my standard unit for a Sony cd player and now it turns on when i open any of the doors.

Is there a remedy for this?


I might be wrong but it sounds like your head unit is using the BSI as the switch? So when the bsi is active when you open the doors, the head unit is turning on with your other illuminated parts.

I will have a look at my own kenwood manual, as it says u can switch some of the wires round the back. Might not be a solution, but its worth a shot.

Does the headunit turn off with the key or.... and does it store stations etc?

It will not switch off with the ignition and does not store any stations


I had this problem and it is explained between the two other posts about sound setups

hope this helps

Here are the ISO for the Berlingo
And the Sony Stereo Harness

53 plate Berlingo Multispace Forte 1.9D Polar White
Thanks for that, i read those threads and wasn't 100% sure that would fix it.

I will give it a go tomorrow and report back.


That's alright

Let us know


53 plate Berlingo Multispace Forte 1.9D Polar White
Hi All,

I have fitted a new Headunit into my Berlingo van yesterday but i have been struggling with the ISO connections and the radio coming on when the van is unlocked !!

I have read through all the stero / speaker threads on here but can not find an answer for my issue.

I can confirm that i have changed round the red and yellow wires. Red to Yellow and Yellow to Red at the ISO.
When the radio is on in the van and i turn the ignition OFF the radio will continue to saty on for approx 1min 30sec then it will turn off. ( dont know where the feed is coming from to keep the radio on that long ) ?? When i unlock the van the raidio comes back on without the key in the ignition. Just on the unlock.

All the radio stations stay in the memory.....

It seems to me that there is a feed being received to the head unit from the van that keeps the switch wire active for a minuite and a half before turning off. I was wondering if this was a BUS wire or something that is being used as a switching live ?

What do you think is the problem and how would i go about fixing it.

After reading these threads it would seem that i need to use the Yellow wire as the permant live feed and run the Red wire to an ignition swithing feed instead of the feed in the ISO connector ( ie uing the windows switch ) ?

So just wondering if anyone can answer these questions as to why
1) the radio comes on with the press of the Unlock Key ( no key in the ignition )
2) the radio stays on for appors 1 minute nad a half before going off ( not ideal when you want to wire a sub, park your car up and its still on for a minuite while walking away sub pumping ) lol
3) How do i cure this issue ?

Many Thanks for your time.
The switched live you´re using is controlled by the BSI which stays active for a while after the ignition is switched off.

IIRC you use the orange wire on the Berlingo plug, which is for accessories, as your switched live. This will go on and off with the ignition.

I had exactly the same problem myself - now sorted.
How much is the fish?
I have a sub but I also have a removable face plate for my stereo and an off button do I use either of the two, normally removing the face plate so my sub turns off anyway and I take no notice of it being on but if I was to sit with the engine off and face plate on it does stay on for a little while like knobbly said it's the bsi.

I'd guess when unlocking the car the bsi becomes active then it turns the stereo on


53 plate Berlingo Multispace Forte 1.9D Polar White
wire the stitched live (normally red) to the drivers electric window live supply.

that will make it come on and off with the ignition

wire the yellow ( perminant live) to the battery.

now it will keep all the stations

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
berlingo 2016 xtr corneri...
Last Post:andy-M
Today 10:45 AM
» Replies: 0
» Views: 9
Checking how much DPF Add...
Last Post:ntm1275
Today 10:40 AM
» Replies: 0
» Views: 10
Roadies' Van - an Update.
Last Post:Roadie
Today 10:22 AM
» Replies: 12
» Views: 1980
Cruise control possible o...
Last Post:cancunia
Today 09:50 AM
» Replies: 3
» Views: 131
2006 1.6hdi - indicators ...
Last Post:geoff
Today 08:30 AM
» Replies: 12
» Views: 316
2012 berlingo radio setti...
Last Post:Luis Rosa
Today 07:37 AM
» Replies: 12
» Views: 279
Can anyone recommend a to...
Last Post:nicebiscuit
Today 07:15 AM
» Replies: 3
» Views: 139
Speedo/milometer fault
Last Post:brajomobil
Today 06:11 AM
» Replies: 11
» Views: 939
Rear reversing sensors
Last Post:Luis Rosa
Today 04:35 AM
» Replies: 1
» Views: 74
Help Surging/loosing powe...
Last Post:michaelg
Today 01:55 AM
» Replies: 5
» Views: 62

Locations of visitors to this page