Thread Rating:
  • 21 Vote(s) - 2.95 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hi guys
A week after buying my berlingo has now developed to faults and im hopimg its just something simple or me being an unlucky sod with motors
After a nighttime drive of approx144 miles the next day the battery light on the dash came on and it was difficult to start
After charging in up for approx seven hours the return trip it came on again about half of the journey back with no lights on or heater just the radio and then the airbag light came on
Battery or alternator just seeing if anyone else has had this problem

First have the battery tested if it tests OK then you're probably looking at the alternator. On the bright side it may just be the battery/alternator connections or cables,
as it's quite common to get poor earth connections due to corrosion or simply that the earthing connector bolts are loose.

[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]
[+] 1 user says Thank You to Ol'Jeffers for this post
Thanks O J
it was just a question for peace of mind really i am getting it checked tomorrow cuz i love the van also
(06-11-2011, 06:39 PM)nidge44 Wrote:  Battery or alternator just seeing if anyone else has had this problem


Alternator. And namely it's voltage regulator.
Problem solved ......needed a new battery
Went to citroen dealer after and they said that the battery light only shows a faulty battery not if the alternator isnt charging and they tested both the old one (faulty cell) and the new one accepting charge when engine started up......couldn't have been more helpfull (citroen Orsett Cock Thurrock)
Hope it helps someone else

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
My Berlingo Camper build....
Last Post:Sootyfoot
Today 05:11 AM
» Replies: 6
» Views: 291
Roof bars for VTR?
Last Post:Jed Clampit
Yesterday 09:40 PM
» Replies: 4
» Views: 86
2005 Berlingo - Aussie Ow...
Last Post:martybelfasthdi
Yesterday 07:50 PM
» Replies: 14
» Views: 263
Eco activated but engine ...
Last Post:doofer
Yesterday 07:50 PM
» Replies: 22
» Views: 504
Front camber out of align...
Last Post:Col
Yesterday 06:46 PM
» Replies: 11
» Views: 240
P1351 fault code.
Last Post:Boxer
Yesterday 06:28 PM
» Replies: 13
» Views: 775
Upgrading DAB radio recep...
Last Post:Tree
Yesterday 06:26 PM
» Replies: 14
» Views: 2522
Overheating & part number...
Last Post:kevin58
Yesterday 05:55 PM
» Replies: 36
» Views: 17327
Last Post:ron
Yesterday 04:20 PM
» Replies: 4
» Views: 90
Speedo light not working?
Last Post:brodfather11
Yesterday 04:11 PM
» Replies: 1
» Views: 45

Locations of visitors to this page