Thread Rating:
  • 15 Vote(s) - 2.73 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Bsi Repaired
#1
Information 
After finding out my Bsi was at fault, ( http://www.berlingoforum.co.uk/showthread.php?tid=1453 ) I decided to see if I could trace the fault myself.
The fault was the Van data B line - none existant. After checking all the 9012 & 9013 data lines were all connected to each other through the bsi connections EP & EH1, I started tracing the signal route back on the pcb. (picture 1)


[Image: 2503vkp.jpg]

Picture 2 Shows the liquid damage which was found on an earlier poke around after the connector EH1 was removed. Also shown is the offending through hole connection which had corroded and was the cause of the fault.

[Image: 35n32af.jpg]

Picture 3 is the pcb after cleaning. Now a better view of the through hole.

[Image: 1ny1rq.jpg]

Last picture, reverse side. This is showing: The repair bridging the through hole to a point further up the board, The EH1 connector soldered back in and the van data lines.

[Image: f0ucmr.jpg]

:thumbsup: Comments Welcome.
2006 2.0hdi 600 with bench seat.  Cool
[+] 6 users say Thank You to Rustscrat for this post
Reply
#2
This is fantastic, having lost a BSI of my own (and a further £200+ to replace it), sharing knowledge over this is invaluable.

How did you know it was the Van Data B line, and subsequently where it was?
Want Help with the Forum? Read Help Documents Here
 [Image: mybbsig.php]

Reply
#3
That, to me at least, is an amazing bit of diagnostic work. Well done and thanks for the great pictures.

Tom
2010 Berlingo Multispace HDi 110 with FAP. Persamos green.

[Image: ab197646.gif]
Reply
#4
Top marks to you for that.
Reply
#5
(08-11-2011, 12:12 AM)Andre Wrote:  This is fantastic, having lost a BSI of my own (and a further £200+ to replace it), sharing knowledge over this is invaluable.

How did you know it was the Van Data B line, and subsequently where it was?

Hi Andre, The Data B faults showed up using a clone diag unit, courtesy of Blueblingo as mine was duff. Three faults- "Data B Engine Relay Unit (Psf1), Data B Switch Steering (cv00) and Data B Airbag Ecu (6570)".
These are all on the 9012/9013 comms line.
Thought at first it might have been a short to earth on the B line but they were all clear so had to be the Bsi unit.
Wiring diagrams were essential, pay'd £30 for them on ebay, (ouch) but these worked a treat and for the extra 10 or so quid 100% better than a Haynes!

Cheers. Confusedalut:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#6
Looking at the 2nd picture, I am amazed that this was fixable.
2005 Berlingo Multispace 1.6i Desire (Iron Grey)

If everything seems to be going well, you have obviously overlooked something.


Reply
#7
(08-11-2011, 10:10 AM)Chris Wrote:  Looking at the 2nd picture, I am amazed that this was fixable.

I was also amazed, well done on fixing it though.

I'll be even more amazed if it doesn't fail in the next year, hope not though mate!
Somedays you're the pigeon, Somedays you're the statue.
Reply
#8
(08-11-2011, 09:45 PM)steve valentine Wrote:  
(08-11-2011, 10:10 AM)Chris Wrote:  Looking at the 2nd picture, I am amazed that this was fixable.

I was also amazed, well done on fixing it though.

I'll be even more amazed if it doesn't fail in the next year, hope not though mate!

I hope so too, according to the fault log this appeared at 18,000 miles. Present mileage is 56,000. If any thing else was going to corrode I'd of thought it should of done by now. Fingers crossed!!
2006 2.0hdi 600 with bench seat.  Cool
[+] 2 users say Thank You to Rustscrat for this post
Reply
#9
(08-11-2011, 10:12 PM)Rustscrat Wrote:  
(08-11-2011, 09:45 PM)steve valentine Wrote:  
(08-11-2011, 10:10 AM)Chris Wrote:  Looking at the 2nd picture, I am amazed that this was fixable.

I was also amazed, well done on fixing it though.

I'll be even more amazed if it doesn't fail in the next year, hope not though mate!

I hope so too, according to the fault log this appeared at 18,000 miles. Present mileage is 56,000. If any thing else was going to corrode I'd of thought it should of done by now. Fingers crossed!!

You may find yourself getting dry solder joints but fingers crossed mate!
Somedays you're the pigeon, Somedays you're the statue.
Reply
#10
Well done you! It shows that many faults on boards can be fixed if you have enough experience and knowledge! Personally I still totally detest surface
mount components. I remember modding the digital filter on an early CD player which had these.........../OJ rambles on for at least five minutes....Confusedtudy:
[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Bottom Ball joint
Last Post:jj9
Today 08:18 PM
» Replies: 5
» Views: 46
peugeot charger
Last Post:geoff
Today 06:35 PM
» Replies: 4
» Views: 113
cutting out HDi 1.6 diese...
Last Post:Col
Today 06:15 PM
» Replies: 18
» Views: 1425
Poor cold startup 1.9
Last Post:Top drive
Today 06:10 PM
» Replies: 34
» Views: 789
hello
Last Post:ron
Today 05:22 PM
» Replies: 1
» Views: 32
Lower Ball Joint
Last Post:brodfather11
Today 03:36 PM
» Replies: 1
» Views: 47
starting problem
Last Post:brodfather11
Today 03:32 PM
» Replies: 1
» Views: 37
Washers not working
Last Post:Redjoe100
Today 03:25 PM
» Replies: 6
» Views: 140
citroen berlingo alarm
Last Post:sks01773
Today 11:28 AM
» Replies: 0
» Views: 33
Reverse light switch prob...
Last Post:ffrenchie
Today 09:48 AM
» Replies: 6
» Views: 107

Locations of visitors to this page