Thread Rating:
  • 8 Vote(s) - 2.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Spring Rubbing issue
#1
Hello all,

I have owned a 04 plate berlingo 2.0 HDi for 3 years. One year into ownership and the front drivers side suspension spring snapped. I got a new one from eurocarparts and fitted it. Ever since fitting it when steering there was a rubbing noise. I found the very top of the spring was rubbing against the cars inner wheel arch.

Things i have considered:

I have does something incorrect when putting it all back together.

I have put the spring in the wrong way around. Looks like it could go in either way though.

The spring is wrong, even though it fits the cups nice.


Any suggestions are welcome. I currently have the stut off and the spring out. Looking through the top mount hole you can see where it has been rubbing.

Note sure what to do now?

Cheers
Bob

euro car part no. 627545140 was fitted.
Found this on another post
"i had a broken spring replaced and the garage had not seated the top bearing correctly which caused a twang on bumps and turns."

Looked at how the top bearing seats and i can not see that as being the problem.
Reply
#2
Can you get a picture of the rubbing ?
Reply
#3
yeah that is a good idea. To dark now to take a good photo but I will upload first thing tomorrow. I'm not the best at describing things so a picture be better.

Looks like the spring has been rubbing agaist the chassis. Right at the top. I have looked at the other side and it is close, but not touching. Not sure how this has occurred. It was the first time i swapped a spring so could well be something i have done.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
increase in a ratchet-typ...
Last Post:saskak
Today 12:36 AM
» Replies: 7
» Views: 119
DW8 engine tapping
Last Post:Hector Scorn
Today 12:30 AM
» Replies: 0
» Views: 11
Rear Wiper Motor
Last Post:madwelshman
Yesterday 10:42 PM
» Replies: 3
» Views: 114
Heater control unit/resis...
Last Post:mreid63
Yesterday 10:34 PM
» Replies: 5
» Views: 339
Loud beeping from radio u...
Last Post:Tonyash
Yesterday 10:13 PM
» Replies: 0
» Views: 23
Facial light replacement
Last Post:Mike
Yesterday 09:23 PM
» Replies: 11
» Views: 289
Reverse light switch prob...
Last Post:willpisme
Yesterday 08:09 PM
» Replies: 7
» Views: 160
Rear hub nut torque setti...
Last Post:geoff
Yesterday 07:31 PM
» Replies: 4
» Views: 96
Heyup
Last Post:polar
Yesterday 07:18 PM
» Replies: 9
» Views: 374
New owner
Last Post:SheilaAnn
Yesterday 04:33 PM
» Replies: 12
» Views: 586

Locations of visitors to this page