Thread Rating:
  • 8 Vote(s) - 3.63 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Idle speed Issues??
#1
Idle speed issues. Has anyone experienced this? I have a 1.8 petrol berlingo and sometimes while driving the engine won't return to normal idle speed and sits at 2000rpm making smooth starts really tricky. it doesn't last and is a random problem. Its really annoying, I have replaced the airflow sensor but the problem remains. Any help would be appreciated.
thanks clare xBig Grin
Reply
#2
Are the revs unruly at idle Clare? As in are they all over the place, or just sit at 2k rpm?
Want Help with the Forum? Read Help Documents Here
 [Image: mybbsig.php]

Reply
#3
By the way, this isn't you is it? http://www.berlingoforum.co.uk/member.ph...e&uid=1628
Want Help with the Forum? Read Help Documents Here
 [Image: mybbsig.php]

Reply
#4
(22-11-2011, 10:59 PM)Andre Wrote:  By the way, this isn't you is it? http://www.berlingoforum.co.uk/member.ph...e&uid=1628

yes thats me i signed in on facebook and it aded me as new lol
(22-11-2011, 11:03 PM)clare baird Wrote:  
(22-11-2011, 10:59 PM)Andre Wrote:  By the way, this isn't you is it? http://www.berlingoforum.co.uk/member.ph...e&uid=1628

yes thats me i signed in on facebook and it aded me as new lol

the revs just sit a 2000rpm dont they they dont go up and down
Reply
#5
You're everywhere! Accounts merged to your original one.

Want Help with the Forum? Read Help Documents Here
 [Image: mybbsig.php]

[+] 1 user says Thank You to Andre for this post
Reply
#6
(22-11-2011, 11:07 PM)Andre Wrote:  You're everywhere! Accounts merged to your original one.

thanks so now when i log in from fb wil it take me to this one i take it?
and my problem have u ever had that?
and it cutsout at round abouts too intermitent can go for ages its fine then all sudden goes again any ideas?
Reply
#7
Hi Clare

Hmmmm. My 2004 model does the odd weird thing at idle from time to time, but I think mine gets a bit upset by the lpg.

Do you mean you've changed the map sensor?

Looks like this map

Have you had a look to see if there are any vacuum leaks, split hoses, that sort of thing? Hissings sounds when car is running....?
Reply
#8
(22-11-2011, 11:42 PM)tucker Wrote:  Hi Clare

Hmmmm. My 2004 model does the odd weird thing at idle from time to time, but I think mine gets a bit upset by the lpg.

Do you mean you've changed the map sensor?

Looks like this map

map sensor been changed twice my bf fixes cars hes bamboozled hes tried all that u said checking for those things
any other siggestions or is it soemthign il have to live with lol
Have you had a look to see if there are any vacuum leaks, split hoses, that sort of thing? Hissings sounds when car is running....?

Reply
#9
any more things i cna look out for for this fault anyone got any suggestions its really annoying
Reply
#10
Most cars like fords its the idle control valve, it's another thing to check.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Running on chip oil
Last Post:polar
Today 04:07 AM
» Replies: 1
» Views: 12
Poor cold startup 1.9
Last Post:Top drive
Today 12:24 AM
» Replies: 40
» Views: 1081
2004 Berlino Aerial
Last Post:brodfather11
Yesterday 10:48 PM
» Replies: 1
» Views: 35
Washers not working
Last Post:Lighty
Yesterday 09:09 PM
» Replies: 11
» Views: 304
Reverse light switch prob...
Last Post:Col
Yesterday 07:22 PM
» Replies: 12
» Views: 263
2005 2.0 HDI Siemens pump...
Last Post:Woodyrvf750
Yesterday 07:05 PM
» Replies: 0
» Views: 32
Fuse is burning all the t...
Last Post:fernandoblas
Yesterday 05:23 PM
» Replies: 12
» Views: 417
HELP! Smashed passenger w...
Last Post:Sootyfoot
Yesterday 04:31 PM
» Replies: 2
» Views: 74
Diagnostic "gear" / Softw...
Last Post:cancunia
Yesterday 04:19 PM
» Replies: 15
» Views: 619
Berlingo Parts
Last Post:malgpz900
Yesterday 10:20 AM
» Replies: 1
» Views: 91

Locations of visitors to this page