Thread Rating:
  • 15 Vote(s) - 3.4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
battery light
#1
i have just bought my van and the battery light is on, when i went to get it the battery was flat, so jump started it and drove 30 miles home in the dark with the headlights on, so im sure the alternator is working, but i have put a new battery on but the battery light is still on?
Reply
#2

Measure the voltage at the battery terminals while the engine is running.
You should see about 13.8 volts. If it's less then check the earth connections for corrosion or loose connectors. If the voltage goes up and down with variations in engine revs then it could be that the voltage regulator is at fault. The regulator is part of the alternator and I believe that you can buy the regulator as an after-market kit but I'm not sure on this but there is a recent post suggesting that these are available. If the alternator, as you have said, is OK then there are a few connectors that may not be as tight as they should be or are corroded.
I hope this helps. :thumbsup:
[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]
[+] 1 user says Thank You to Ol'Jeffers for this post
Reply
#3
I have something similar.
Sometimes when I'm sat at junctions with the engine idling, the battery light will momentarily light up and bleep. doesn't do it when first fired up when sat on the drive, or parked up with the engine running, only occasionaly when i pull up at junctions.
Lights don't go dim or anything and all the rest of the electrics seem in order.
Reply
#4
The voltage is sitting at 11.4 with the engine at idle and it rises about .3 when its at 3k rpm,il check the straps then start looking for a new regulator.
Reply
#5
(25-11-2011, 07:04 PM)Danz37 Wrote:  The voltage is sitting at 11.4 with the engine at idle and it rises about .3 when its at 3k rpm,il check the straps then start looking for a new regulator.

If that's with the new battery then I'd say that there's little or no charge from the alternator. A good battery should read at least 12v and your is less so there is a discharge which will get worse. You need to get this fixed or you could risk the new battery as well. :eek:
[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Berlingo won't start 2009...
Last Post:brodfather11
Today 06:20 AM
» Replies: 8
» Views: 180
1.6 16v petrol cambelt
Last Post:polar
Today 06:13 AM
» Replies: 1
» Views: 27
Insurance!
Last Post:fcamp
Yesterday 10:52 PM
» Replies: 6
» Views: 830
citroen berlingo desire 1...
Last Post:sks01773
Yesterday 10:47 PM
» Replies: 2
» Views: 41
B9 DPF Tank Top-Up
Last Post:Lighty
Yesterday 10:06 PM
» Replies: 5
» Views: 113
Rear light Cluster
Last Post:Peter Guy
Yesterday 09:57 PM
» Replies: 2
» Views: 31
2012 enterprise berlingo ...
Last Post:CourierJim
Yesterday 09:03 PM
» Replies: 6
» Views: 121
Head gasket failure.
Last Post:Civvic
Yesterday 08:08 PM
» Replies: 13
» Views: 361
At last
Last Post:Gerald Bostock
Yesterday 08:06 PM
» Replies: 9
» Views: 332
Conversion from manual to...
Last Post:Civvic
Yesterday 07:58 PM
» Replies: 1
» Views: 90

Locations of visitors to this page