Thread Rating:
  • 23 Vote(s) - 3.35 Average
  • 1
  • 2
  • 3
  • 4
  • 5
leaking Modutop
We have a berlingo 53, 2.0HDI with modutop. we have had lots of prolems with a wet drivers side footwell. Eventually after a very wet weekend, so much water got in that the BSi unit got wet and needed replacing. The citroen dealers resealed the windscreen €800. Next day, leaking again, wind screen resealed for second time. Week later, problem again, now they think it's the modutop and would cost a fortune to replace.
Has anyone successfully resealed the modutop with silicone. any photo's would help.
I hope the Citroen dealer has given you a suitable refund for mis-diagnosing the leak. Did he check the aerial mounting and the front scuttle?
Removing and re-fitting a Modutop is a BIG job. There is only one company who has done it that I know of and they are are boat repair company in Sheerness in Kent.
The only possible short cut and alternative to complete removal and re-fitting would be to carefully attempt re-sealing using a thin and mobile sealant such as that used
for sealing thermostats into washing machine drums. You'll need to inject the sealant under the existing rubber seal as far in as is possible using a very fine nozzle.
I think you can only safely raise the edge of the rubber seal by a few millimeters. DO NOT try this using silicon sealant.
Because of the difficulty of the job I would make 100% sure that it is the Modutop leaking and that the water is not coming from anywhere else.
I have to admit that when I first read your problem I immediately thought that the scuttle under the wiper arms was blocked with debris and the water then would be leaking in through the bulkhead.
Hope you manage to sort this out.....please get back to us if you do.:thumbsup:
[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]
[+] 1 user says Thank You to Ol'Jeffers for this post

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Bump and Run - Am I right...
Last Post:jj9
Today 09:44 AM
» Replies: 13
» Views: 198
Dead BSI unit?
Last Post:ghost123uk
Today 09:03 AM
» Replies: 5
» Views: 129
Injectors and B9 series.....
Last Post:Opensauce
Today 06:55 AM
» Replies: 1
» Views: 53
2004 2.0HDi Cruise Contro...
Last Post:brajomobil
Today 06:29 AM
» Replies: 1
» Views: 57
Radio not working and ele...
Last Post:pscotty
Today 04:02 AM
» Replies: 0
» Views: 27
splayed rear wheels
Last Post:jj9
Yesterday 10:36 PM
» Replies: 7
» Views: 110
Dandav1985's Mk3 Berlingo
Last Post:Jed Clampit
Yesterday 10:16 PM
» Replies: 8
» Views: 252
Still on the elusive 4x10...
Last Post:doofer
Yesterday 08:47 PM
» Replies: 3
» Views: 141
Car smell...
Last Post:doofer
Yesterday 08:03 PM
» Replies: 1
» Views: 94
srceen wash pump.
Last Post:landcrab
Yesterday 07:18 PM
» Replies: 7
» Views: 206

Locations of visitors to this page