Thread Rating:
  • 8 Vote(s) - 3.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
BSI at fault??
Had a quck look on forum for answers to this ,so sorry if i've missed it.My vehicle is a 2000 Multispace 1400 petrol and the problem i have is that since i've had the car the central locking,rear wiper and interior heater have not worked.The first two i can live with but now the colder weather is upon us i need the heater to work to clear the screen and keep my old bones warm!
I have checked all the fuses and the fan worked when tested by a mechanic friend who seems to think it could be the BSI unit which is at fault.Any suggestions??

You can perform a reset on the Berlingo by taking out a big fuse, think theres a guide on how to do it on a ecu repair site, begins with a B but cant remember it. It may work.
[+] 1 user says Thank You to tommyberlingo for this post
If you have an electrical feed to the rear wiper it's most likely a seized/worn wiper motor. Had to replace mine on a 2002 model. Took it off and striped it down but the gearing was u/s. Hopefully your motor will be bolted on. Mine was poprivited with huge rivets that I didn't have. Local garage did it.
Ex 1.4 Berlingo Multispace
[+] 1 user says Thank You to Landmark for this post
I don't think that the heater would be in any way controlled by the BSI.
Possibly the blower fan may be but I can't see why it should be. Maybe another Citroen quirk.
Even with no fan assistance you should get some warmth.
[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Injectors and B9 series.....
Last Post:Opensauce
Today 06:55 AM
» Replies: 1
» Views: 39
2004 2.0HDi Cruise Contro...
Last Post:brajomobil
Today 06:29 AM
» Replies: 1
» Views: 50
Radio not working and ele...
Last Post:pscotty
Today 04:02 AM
» Replies: 0
» Views: 21
splayed rear wheels
Last Post:jj9
Yesterday 10:36 PM
» Replies: 7
» Views: 103
Dandav1985's Mk3 Berlingo
Last Post:Jed Clampit
Yesterday 10:16 PM
» Replies: 8
» Views: 243
Bump and Run - Am I right...
Last Post:Jed Clampit
Yesterday 10:13 PM
» Replies: 11
» Views: 161
Still on the elusive 4x10...
Last Post:doofer
Yesterday 08:47 PM
» Replies: 3
» Views: 135
Car smell...
Last Post:doofer
Yesterday 08:03 PM
» Replies: 1
» Views: 82
Dead BSI unit?
Last Post:Kez
Yesterday 07:22 PM
» Replies: 4
» Views: 117
srceen wash pump.
Last Post:landcrab
Yesterday 07:18 PM
» Replies: 7
» Views: 204

Locations of visitors to this page